This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1016649 - Clicking ASSOCIATE button to associate content source to repository displays error in UI
Clicking ASSOCIATE button to associate content source to repository displays ...
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Content (Show other bugs)
JON 3.2
Unspecified Unspecified
high Severity high
: GA
: JON 3.2.0
Assigned To: Jirka Kremser
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 09:24 EDT by Sunil Kondkar
Modified: 2014-01-02 15:36 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-02 15:36:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (72.30 KB, image/png)
2013-10-08 09:25 EDT, Sunil Kondkar
no flags Details

  None (edit)
Description Sunil Kondkar 2013-10-08 09:24:38 EDT
Description of problem:

Clicking on the button 'ASSOCIATE' on to associate content source to repository displays error in UI. There are no errors in logs.

Please refer the attached screenshot.

Version-Release number of selected component (if applicable):

Version: 3.2.0.ER3
Build Number: c0742ed:cbad264

How reproducible:

Always

Steps to Reproduce:

1. Navigate to Administration->Content>Repositories
2. Click on link 'JBoss Patches'.
3. Click on the button ASSOCIATE in the section 'Content Sources Associated with This Repository'.

Actual results:

Clicking ASSOCIATE button to associate content source to repository displays error in UI

Expected results:

User should be able to associate content source to repository.

Additional info:
Comment 1 Sunil Kondkar 2013-10-08 09:25:39 EDT
Created attachment 809282 [details]
Screenshot
Comment 2 Heiko W. Rupp 2013-10-08 12:23:21 EDT
rhq/content/repo-plain.xhtml:336 says 
     <!-- The ability to associate/disassociate repos with content sources is not needed for JON. -->

If this is the case, we should probably disable that part
Comment 3 Heiko W. Rupp 2013-10-10 07:10:04 EDT
( this works in JON 3.1.2 )
Comment 4 Heiko W. Rupp 2013-10-11 08:12:37 EDT
This may have to do with the move of portal war from / to /portal

Jirka, can you please look into this?
Comment 5 Jirka Kremser 2013-10-14 10:19:30 EDT
It was a regression caused by the '/' -> '/portal' move


branch:  release#jon3.2.x
link:    http://git.fedorahosted.org/cgit/rhq/rhq.git/commit/?id=c128a7fa9
time:    2013-10-14 16:16:37 +0200
commit:  c128a7fa91dcba89573a47351f903f312959dce6
author:  Jirka Kremser - jkremser@redhat.com
message: [BZ 1016649] - Clicking ASSOCIATE button to associate content source to
         repository displays error in UI - removing the "/portal"
         prefix, because the attribute "template" of the Facelets'
         element "composition" expects the relative path as a value.
Comment 6 Simeon Pinder 2013-12-13 11:13:51 EST
Moving this to ON_QA, as discussed in triage call (myarboro,loleary,spinder). This is already in the GA tag but somehow we didn't set this to ON_QA.
Comment 7 Sunil Kondkar 2013-12-16 04:59:24 EST
 Verified on Version : 3.2.0.GA Build Number : dcb8b6f:734bd56

Note You need to log in before you can comment on or make changes to this bug.