Bug 1016652 - Unify console logs of post-install configuration tasks
Unify console logs of post-install configuration tasks
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Installer (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity low
: ER6
: EAP 6.2.0
Assigned To: Thomas Hauser
Petr Kremensky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 09:25 EDT by Petr Kremensky
Modified: 2017-10-09 20:23 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:19:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Kremensky 2013-10-08 09:25:53 EDT
Description of problem:
 Currently only domain post-install configuration is logged to console. I think we should either log both or none of them.

Version-Release number of selected component (if applicable):
 EAP 6.2.0 ER5

How reproducible:
 always

Steps to Reproduce:
 1. Configure some of post-install tasks.
 2. Observe console for post-install configuration logs.

Actual results:
 Only domain post-install configuration is logged to console.

Expected results:
 Both or none of server modes should be logged to console.
Comment 1 Thomas Hauser 2013-10-15 10:33:58 EDT
We now print all of the output from all commands. They are kept within a new file: InstallationLog.txt. This new file will also contain the server startup process, as well as any other external commands that are being run.

The postinstall-*.log files have been removed, since this new file will contain all of the contents anyway. 

This mirrors the FSW et al installer logging methodology.
Comment 2 Petr Kremensky 2013-10-18 05:39:49 EDT
All possible information (also CLI commnad outputs) can be now found inside InstallationLog.txt file.

Verified on EAP 6.2.0.ER6 installer.

Note You need to log in before you can comment on or make changes to this bug.