Bug 1016678 - Notify user when unmanagable AS7 is discovered
Notify user when unmanagable AS7 is discovered
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 6 (Show other bugs)
JON 3.2
Unspecified Unspecified
unspecified Severity medium
: ER01
: JON 3.3.0
Assigned To: Libor Zoubek
Armine Hovsepyan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 10:05 EDT by Libor Zoubek
Modified: 2015-11-01 19:43 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-11 09:02:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Libor Zoubek 2013-10-08 10:05:16 EDT
Description of problem:

When you start AS7 without http management interface enabled/defined, agent discovers such AS7 and detects (or not detects) management port as 0. When user imports such server it never comes up. User has to know, that port 0 means that agent did not detect the port => why that happened? user has to find out he's missing http-management interface definition within his configuration.

This might be quite common mistake, because when you run stock EAP6.1.1 in domain mode with host-slave.xml (host controller only), http interface is not defined in this default config.

Version-Release number of selected component (if applicable):
JON 3.2.ER3

How reproducible: always


Steps to Reproduce:
1. unzip EAP6
2. cp -a domain machine1
3. run domain controller ./domain.sh --host-config-file=host-master.xml
4. run host controller ./domain.sh -Djboss.domain.base.dir=../machine1 --host-config=host-slave.xml -Djboss.domain.master.address=127.0.0.1


Actual results: host controler is discovered with management port 0, when imported agent throws exception with invalid port

Caused by: java.lang.IllegalArgumentException: Invalid port: 0
        at org.rhq.modules.plugins.jbossas7.ASConnection.<init>(ASConnection.java:165)
        at org.rhq.modules.plugins.jbossas7.ASConnection.newInstanceForServerPluginConfiguration(ASConnection.java:230)
        at org.rhq.modules.plugins.jbossas7.BaseServerComponent.start(BaseServerComponent.java:98)
        at sun.reflect.GeneratedMethodAccessor56.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:616)


Expected results: agent should tell the user about missing http-management-interface in his configuration.
it should:
not discover such host controller at all, but explain everything into log file
OR: discover such host controller, but when imported, provide hint to user, so he can fix his setup

Additional info:
Comment 1 Simeon Pinder 2013-11-08 09:41:26 EST
Moving to unspecified target milestone as only JON 3.2.0 'blockers'(https://url.corp.redhat.com/bz-jon32-blockers-list-notmodified-nodocs) will make it into subsequent builds after ER5.
Comment 4 Libor Zoubek 2014-08-22 19:04:05 EDT
Thomas this might be already implemented within Bug 1119240. If port is detected as 0 we throw PluginConfigurationException with appropriate message, so user gets a clue what to do.
Comment 5 Thomas Segismont 2014-08-25 08:11:00 EDT
Just checked the changes from Bug 1119240. Yes, the IPCE has an appropriate message now. No additional work needed.
Comment 6 Jan Bednarik 2014-09-11 09:16:23 EDT
Moving to VERIFIED.

If the http-interface is not specified in host-slave.xml, the host controller appears to be down. As described in BZ 1119240 Comment 2, there appears a triangle icon next to availability icon which, when clicked, opens the window with further explanation: "Unable to detect management port. Please enable management HTTP interface on and then set correct port number in Connection Settings of this resource". The same warning is logged in agent.log file as a WARN message while starting the host controller.

Version:3.3.0.ER02
Build Number:4fbb183:7da54e2

Note You need to log in before you can comment on or make changes to this bug.