Bug 1016680 - MSG: add hint about 'reset-failed' when systemctl start fails due to rate limit
MSG: add hint about 'reset-failed' when systemctl start fails due to rate limit
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd (Show other bugs)
7.0
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Michal Sekletar
Tereza Cerna
:
Depends On:
Blocks: 802465
  Show dependency treegraph
 
Reported: 2013-10-08 10:13 EDT by Michal Schmidt
Modified: 2015-11-19 09:55 EST (History)
7 users (show)

See Also:
Fixed In Version: systemd-219-4.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 09:55:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Schmidt 2013-10-08 10:13:22 EDT
(This is related to bug 821723, which asked for ignoring the services' rate limit for systemctl invocations, but was closed as NOTABUG.)

Currently when "systemctl restart foo.service" fails due to the rate limit, a generic error message is printed:

  Job for foo.service failed. See 'systemctl status foo.service'
  and 'journalctl -xn' for details.

In http://lists.freedesktop.org/archives/systemd-devel/2012-September/006530.html Lennart suggested a more helpful error message should be shown:

"Starting foobar.service has been attempted too often too quickly, the
repeated start of the unit has been refused. To force a start please
invoke 'systemctl reset-failed foobar.service' followed by 'systemctl
start foobar.service' again."


Version-Release number of selected component (if applicable):
systemd-208-2.fc20.x86_64

How reproducible:
always

Steps to Reproduce:
1. for i in $(seq 1 10); do systemctl restart sshd; done
2.
3.

Actual results:
A generic error message.

Expected results:
A helpful error message that mentions the possibility of using "reset-failed".
Comment 8 errata-xmlrpc 2015-11-19 09:55:26 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2092.html

Note You need to log in before you can comment on or make changes to this bug.