Bug 1016683 - quota: directory quota limit crossed, if limit is changed while I/O is happening
quota: directory quota limit crossed, if limit is changed while I/O is happening
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
mainline
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Pranith Kumar K
: ZStream
Depends On: 1002530
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 10:16 EDT by Pranith Kumar K
Modified: 2014-04-17 07:49 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1002530
Environment:
Last Closed: 2014-04-17 07:49:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-10-08 10:23:00 EDT
REVIEW: http://review.gluster.org/6052 (cluster/afr: Handle quota size xattr separately in lookup) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 2 Anand Avati 2013-10-10 13:39:02 EDT
COMMIT: http://review.gluster.org/6052 committed in master by Anand Avati (avati@redhat.com) 
------
commit 86f936f4381a8d8490255ef439ec3c44ca79fe76
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Tue Oct 8 17:14:40 2013 +0530

    cluster/afr: Handle quota size xattr separately in lookup
    
    Quota size xattrs are not maintained by afr. There is a
    possibility that they differ even when both the directory
    changelog xattrs suggest everything is fine. So if there is at
    least one 'source' check among the sources which has the maximum
    quota size. Otherwise check among all the available ones for
    maximum quota size. This way if there is a source and stale copies
    it always votes for the 'source'.
    
    Change-Id: Ia222379cbafa7043dd03f533c105860f2c7b8b0d
    BUG: 1016683
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/6052
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Varun Shastry <vshastry@redhat.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 3 Anand Avati 2013-10-16 06:37:56 EDT
REVIEW: http://review.gluster.org/6098 (cluster/afr: Remove 'max' from the log) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 4 Anand Avati 2013-10-17 05:26:37 EDT
COMMIT: http://review.gluster.org/6098 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 5033d450ca039b77b9245006e1de7c950754dbb1
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Wed Oct 16 15:58:33 2013 +0530

    cluster/afr: Remove 'max' from the log
    
    This patch avoids giving more info to the user about the
    internal heuristic employed in afr, for quota sizes.
    
    Change-Id: Ice3a164399f09b6967500ec0c17dc340e7ae9aba
    BUG: 1016683
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/6098
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
    Tested-by: Vijay Bellur <vbellur@redhat.com>
Comment 5 Niels de Vos 2014-04-17 07:49:18 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.