Bug 1016712 - Packstack tempest install fails on F19
Packstack tempest install fails on F19
Status: CLOSED WORKSFORME
Product: RDO
Classification: Community
Component: openstack-packstack (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rushil Chugh
Nir Magnezi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 10:52 EDT by Steven Hardy
Modified: 2014-03-17 00:00 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-11 10:30:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output log after updating answer file (5.79 KB, text/plain)
2013-11-11 10:24 EST, Rushil Chugh
no flags Details
Updated answer file (13.16 KB, text/plain)
2013-11-11 10:28 EST, Rushil Chugh
no flags Details

  None (edit)
Description Steven Hardy 2013-10-08 10:52:28 EDT
Description of problem:
Attempting to install Tempest via packstack fails on F19 due to not finding mysql-devel (mariadb-devel is installed)

Version-Release number of selected component (if applicable):
openstack-packstack-2013.2.1-0.10.dev763.fc20.noarch

How reproducible:
Always

Steps to Reproduce:
1. Configure your answerfile with the following:
cat packstack_localhost_allinone.txt | grep TEMPEST
CONFIG_PROVISION_TEMPEST=y
CONFIG_PROVISION_TEMPEST_REPO_URI=https://github.com/openstack/tempest.git
CONFIG_PROVISION_TEMPEST_REPO_REVISION=master

2. packstack --answer-file packstack_localhost_allinone.txt 


Actual results:
Fails:

ERROR : Error during puppet run : Error: Could not find package mysql-devel

Expected results:
Install works.

Additional info:

^[[1;31mError: Could not find package mysql-devel^[[0m
^[[1;31mError: /Stage[main]/Tempest/Package[mysql-devel]/ensure: change from absent to present failed: Could not find package mysql-devel^[[0m
^[[mNotice: /Stage[main]/Tempest/Tempest_glance_id_setter[image_ref]/ensure: created^[[0m
^[[mNotice: /Stage[main]/Tempest/Tempest_glance_id_setter[image_ref_alt]/ensure: created^[[0m
^[[mNotice: Finished catalog run in 37.68 seconds^[[0m

2013-10-08 15:42:36::ERROR::run_setup::913::root:: Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 908, in main
    _main(confFile)
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 577, in _main
    runSequences()
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 554, in runSequences
    controller.runAllSequences()
  File "/usr/lib/python2.7/site-packages/packstack/installer/setup_controller.py", line 90, in runAllSequences
    sequence.run(self.CONF)
  File "/usr/lib/python2.7/site-packages/packstack/installer/core/sequences.py", line 105, in run
    step.run(config=config)
  File "/usr/lib/python2.7/site-packages/packstack/installer/core/sequences.py", line 52, in run
    raise SequenceError(str(ex))
SequenceError: Error during puppet run : Error: Could not find package mysql-devel^[[0m
Comment 1 Rushil Chugh 2013-11-08 15:51:10 EST
Hi Steven
Was there an existing answer file when you ran the following command: 
packstack --answer-file packstack_localhost_allinone.txt ?


(In reply to Steven Hardy from comment #0)
> Description of problem:
> Attempting to install Tempest via packstack fails on F19 due to not finding
> mysql-devel (mariadb-devel is installed)
> 
> Version-Release number of selected component (if applicable):
> openstack-packstack-2013.2.1-0.10.dev763.fc20.noarch
> 
> How reproducible:
> Always
> 
> Steps to Reproduce:
> 1. Configure your answerfile with the following:
> cat packstack_localhost_allinone.txt | grep TEMPEST
> CONFIG_PROVISION_TEMPEST=y
> CONFIG_PROVISION_TEMPEST_REPO_URI=https://github.com/openstack/tempest.git
> CONFIG_PROVISION_TEMPEST_REPO_REVISION=master
> 
> 2. packstack --answer-file packstack_localhost_allinone.txt 
> 
> 
> Actual results:
> Fails:
> 
> ERROR : Error during puppet run : Error: Could not find package mysql-devel
> 
> Expected results:
> Install works.
> 
> Additional info:
> 
> ^[[1;31mError: Could not find package mysql-devel^[[0m
> ^[[1;31mError: /Stage[main]/Tempest/Package[mysql-devel]/ensure: change from
> absent to present failed: Could not find package mysql-devel^[[0m
> ^[[mNotice: /Stage[main]/Tempest/Tempest_glance_id_setter[image_ref]/ensure:
> created^[[0m
> ^[[mNotice:
> /Stage[main]/Tempest/Tempest_glance_id_setter[image_ref_alt]/ensure:
> created^[[0m
> ^[[mNotice: Finished catalog run in 37.68 seconds^[[0m
> 
> 2013-10-08 15:42:36::ERROR::run_setup::913::root:: Traceback (most recent
> call last):
>   File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py",
> line 908, in main
>     _main(confFile)
>   File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py",
> line 577, in _main
>     runSequences()
>   File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py",
> line 554, in runSequences
>     controller.runAllSequences()
>   File
> "/usr/lib/python2.7/site-packages/packstack/installer/setup_controller.py",
> line 90, in runAllSequences
>     sequence.run(self.CONF)
>   File
> "/usr/lib/python2.7/site-packages/packstack/installer/core/sequences.py",
> line 105, in run
>     step.run(config=config)
>   File
> "/usr/lib/python2.7/site-packages/packstack/installer/core/sequences.py",
> line 52, in run
>     raise SequenceError(str(ex))
> SequenceError: Error during puppet run : Error: Could not find package
> mysql-devel^[[0m
Comment 2 Steven Hardy 2013-11-11 09:46:56 EST
(In reply to Rushil Chugh from comment #1)
> Hi Steven
> Was there an existing answer file when you ran the following command: 
> packstack --answer-file packstack_localhost_allinone.txt ?

Yes, I was running packstack repeatedly with the same answerfile
Comment 3 Rushil Chugh 2013-11-11 10:23:07 EST
Steven
I made the requisite changes to the answer file and it ran successfully for me. I am attaching my console output as well as the updated answer file for reference. I am marking the bug as closed.
Regards
Rushil
Comment 4 Rushil Chugh 2013-11-11 10:24:00 EST
Created attachment 822466 [details]
Output log after updating answer file
Comment 5 Rushil Chugh 2013-11-11 10:28:40 EST
Created attachment 822473 [details]
Updated answer file

Note You need to log in before you can comment on or make changes to this bug.