Bug 1016759 - (DE5692) Subscription Management Applications: when attaching subscriptions, navigating between "available subscriptions" pagination resets selected Subscription Quantity to default max
Subscription Management Applications: when attaching subscriptions, navigatin...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Customer Portal
Classification: Red Hat
Component: Subscriptions/RHSM (Show other bugs)
unspecified
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Tim Moran
Jon Allen
:
Depends On:
Blocks: 1289374
  Show dependency treegraph
 
Reported: 2013-10-08 12:02 EDT by Felix Dewaleyne
Modified: 2015-12-15 17:12 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-31 13:07:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 507993 None None None Never

  None (edit)
Comment 1 Xixi 2013-10-08 13:29:25 EDT
(In reply to comment #0)
Walked through this with Felix just now and I can confirm that this is a problem for Subscription Management Applications for at least SAM and Satellite (haven't tried the others yet but likely the same).  Basically when attaching subscriptiosn for a Subscription Management Application, when navigating to other pages in "available subscriptions" pop-up, whatever quantities selected for subscriptions in hte previous page(s) are lost and get reset to the default which is the maximum available on the acct.

This is cumbersome to users since even with the workaround (see "Additional info") it's time-consuming to attach subscriptions, and they can accidentally exhaust subscriptions on the acct (or shared accts). 

Description of problem: (see above)

Version-Release number of selected component (if applicable):
current

How reproducible:
always

Steps to Reproduce:
1. go to https://access.redhat.com/management/distributors/ with an acct that has >10 types of available subscriptions.
2. pick a Subscriptions Management Application or create one.
3. attach subscriptions - pick something of quantity "1" out of max quantity >1 from the first page (page 1) in the "available subscriptions" pop-up
4. don't click "attached selected" yet, click onto the next page (page 2) of available subscriptions and pick something else with quantity "1" out of max quantity >1 
5. select "attach subscriptions" and wait for refresh to complete

Actual results:
selected subscriptions on the earlier pages of "available subscriptions" are attached with *default* quantities, which is the max available

Expected results:
all selected subscriptions are attached with the *chosen* quantities

Additional info:
it seems like the information regarding the selected Subscription quanity gets lost in pagination.

Workaround is to either:
a) if you don't have too many available subscriptions - choose to show more than 10 subscriptions on one page in the "Available Subscriptions" pop-up so you can attach all the subscriptions from one page.
b) attach subscriptions from one page, select "Attach Selected", wait til it completes and page is refreshed, then attach next subscriptions.

Note You need to log in before you can comment on or make changes to this bug.