Bug 1016787 - Image is not able to resize root fs without reboot
Image is not able to resize root fs without reboot
Status: CLOSED DUPLICATE of bug 977028
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: guest-images (Show other bugs)
6.5
x86_64 Linux
unspecified Severity high
: rc
: 6.5
Assigned To: Joey Boggs
Jaroslav Henner
:
Depends On:
Blocks: 1052453 1100959
  Show dependency treegraph
 
Reported: 2013-10-08 12:57 EDT by Jaroslav Henner
Modified: 2014-05-24 10:29 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-24 10:21:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Henner 2013-10-08 12:57:58 EDT
Description of problem:
The image is not able to get resized using cloud init, without a reboot

Version-Release number of selected component (if applicable):
rhel-server-x86_64-kvm-6.4_20130130.0-9-sda

How reproducible:
100%

Steps to Reproduce:
1. Boot the image with cloud-config specified below
2.
3.

Actual results:
root fs not resized

Expected results:
root fs resized

Additional info:
used this user-data for cloud-init:
#cloud-config
growpart:
  mode: auto
  devices: ['/']
Comment 3 RHEL Product and Program Management 2013-10-13 21:43:49 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 Jaroslav Henner 2014-02-13 10:33:24 EST
No it didn't. I don't think one should be required to modify an image for such a basic thing.
Comment 11 Jaroslav Henner 2014-05-24 10:21:28 EDT
Closing as a dup of 977028 because 977028 is going to be fixed in 6.5 and I think no new 6.4 guest image won't be released.

*** This bug has been marked as a duplicate of bug 977028 ***

Note You need to log in before you can comment on or make changes to this bug.