Bug 1016826 - Cannot set disk interface in user portal
Cannot set disk interface in user portal
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-userportal (Show other bugs)
unspecified
x86_64 Linux
urgent Severity high
: ---
: 3.3.1
Assigned To: Daniel Erez
Aharon Canan
storage
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 14:48 EDT by DHC
Modified: 2016-02-10 13:57 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-25 07:06:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20003 None None None Never
oVirt gerrit 20038 None None None Never

  None (edit)
Description DHC 2013-10-08 14:48:33 EDT
he Add disk UI in the User Portal  does not populate the interface pull-down. Nor will it allow the creation of a new virtual disk as a result. The error states insufficient permissions however the user is assigned PowerUserRole at the cluster level and on the associated storage domain(s).

Engine built from commit: 31cd5339cfda6ad78f5d3a1ff08ad666f734f814

2013-10-08 12:53:15,378 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (ajp--127.0.0.1-8702-10) Correlation ID: 567417ad, Job ID: 6f774854-920b-4217-9906-a484841b843a, Call Stack: null, Custom Event ID: -1, Message: VM sdfa was created by ovirttest.
2013-10-08 12:53:15,396 INFO  [org.ovirt.engine.core.bll.AddVmFromScratchCommand] (ajp--127.0.0.1-8702-10) Lock freed to object EngineLock [exclusiveLocks= key: sdfa value: VM_NAME
, sharedLocks= ]
2013-10-08 12:53:15,433 INFO  [org.ovirt.engine.core.bll.MultipleActionsRunner] (ajp--127.0.0.1-8702-10) MultipleActionsRunner of type AddVmInterface invoked with no actions
2013-10-08 12:53:15,445 INFO  [org.ovirt.engine.core.bll.MultipleActionsRunner] (ajp--127.0.0.1-8702-10) MultipleActionsRunner of type UpdateVmInterface invoked with no actions
2013-10-08 12:53:15,459 INFO  [org.ovirt.engine.core.bll.MultipleActionsRunner] (ajp--127.0.0.1-8702-10) MultipleActionsRunner of type RemoveVmInterface invoked with no actions
2013-10-08 12:53:19,540 ERROR [org.ovirt.engine.core.bll.GetVirtioScsiControllersQuery] (ajp--127.0.0.1-8702-10) Query execution failed due to insufficient permissions.
2013-10-08 12:54:29,015 WARN  [org.ovirt.engine.core.bll.AddDiskCommand] (ajp--127.0.0.1-8702-10) CanDoAction of action AddDisk failed. Reasons:VAR__ACTION__ADD,VAR__TYPE__VM_DISK,VALIDATION.DISK_INTERFACE.NOT_NULL
2013-10-08 12:54:34,891 ERROR [org.ovirt.engine.core.bll.GetVirtioScsiControllersQuery] (ajp--127.0.0.1-8702-10) Query execution failed due to insufficient permissions.
2013-10-08 12:56:14,937 ERROR [org.ovirt.engine.core.bll.GetVirtioScsiControllersQuery] (ajp--127.0.0.1-8702-9) Query execution failed due to insufficient permissions.
2013-10-08 12:56:27,095 WARN  [org.ovirt.engine.core.bll.AddDiskCommand] (ajp--127.0.0.1-8702-4) CanDoAction of action AddDisk failed. Reasons:VAR__ACTION__ADD,VAR__TYPE__VM_DISK,VALIDATION.DISK_INTERFACE.NOT_NULL
Comment 1 Sandro Bonazzola 2013-11-25 07:06:33 EST
oVirt 3.3.1 has been released

Note You need to log in before you can comment on or make changes to this bug.