This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1016829 - Connects but disconnects immediately: platform/nm-linux-platform.c add_object(): Netlink error: Unspecific failure
Connects but disconnects immediately: platform/nm-linux-platform.c add_object...
Status: CLOSED DUPLICATE of bug 1018317
Product: Fedora
Classification: Fedora
Component: NetworkManager-openvpn (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 15:02 EDT by Jacob Emcken
Modified: 2013-11-09 09:31 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-17 03:16:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
relevant message.log (censored) (4.25 KB, text/x-log)
2013-10-08 15:02 EDT, Jacob Emcken
no flags Details

  None (edit)
Description Jacob Emcken 2013-10-08 15:02:44 EDT
Created attachment 809499 [details]
relevant message.log (censored)

Description of problem:

VPN connection disconnects immediately


Version-Release number of selected component (if applicable):

NetworkManager-openvpn.x86_64        1:0.9.8.2-3.fc20           installed       
NetworkManager-openvpn-gnome.x86_64  1:0.9.8.2-3.fc20           installed       
openvpn.x86_64                       2.3.2-4.fc20               installed



How reproducible:

Connect using the right top Gnome 3 menu selecting the VPN connection.


Actual results:

Connects for a sec then disconnects.


Expected results:

Stays connected

Additional info:

I've attached the output in the message.log

I've tried to censor it hope I've hid the right things (not too much and not too little :)

Let me know if you need more info.
Comment 1 Jacob Emcken 2013-10-08 15:04:50 EDT
btw connecting from the terminal works using

    sudo openvpn vpn-config.ovpn


Though DNS servers isn't configured this way (perhaps other things), only tried to ping internal IP's.
Comment 2 Ugo Viti 2013-10-11 15:10:54 EDT
I confirm this bug (same version).

follow the relevant logs during openvpn connection:

Oct 11 21:04:46 jlt NetworkManager[541]: <info> Starting VPN service 'openvpn'...
Oct 11 21:04:49 jlt NetworkManager[541]: <info> VPN service 'openvpn' started (org.freedesktop.NetworkManager.openvpn), PID 11107
Oct 11 21:04:49 jlt NetworkManager[541]: <info> VPN service 'openvpn' appeared; activating connections
Oct 11 21:04:49 jlt NetworkManager[541]: <info> VPN connection 'XXXXXXXX' (ConnectInteractive) reply received.
Oct 11 21:04:49 jlt NetworkManager[541]: <info> VPN plugin state changed: starting (3)
Oct 11 21:04:49 jlt NetworkManager[541]: <info> VPN connection 'XXXXXXXX' (Connect) reply received.
Oct 11 21:04:49 jlt nm-openvpn[11109]: OpenVPN 2.3.2 x86_64-redhat-linux-gnu [SSL (OpenSSL)] [LZO] [EPOLL] [PKCS11] [eurephia] [MH] [IPv6] built on Sep 12 2013
Oct 11 21:04:49 jlt nm-openvpn[11109]: WARNING: No server certificate verification method has been enabled.  See http://openvpn.net/howto.html#mitm for more info.
Oct 11 21:04:49 jlt nm-openvpn[11109]: NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
Oct 11 21:04:49 jlt NetworkManager: ** Message: openvpn started with pid 11109
Oct 11 21:04:49 jlt nm-openvpn[11109]: UDPv4 link local: [undef]
Oct 11 21:04:49 jlt nm-openvpn[11109]: UDPv4 link remote: [AF_INET]XX.XX.XX.XX:XXXX
Oct 11 21:04:50 jlt nm-openvpn[11109]: [XXXXXXXXXXXXX] Peer Connection Initiated with [AF_INET]XX.XX.XX.XX:XXXX
Oct 11 21:04:53 jlt nm-openvpn[11109]: TUN/TAP device tun0 opened
Oct 11 21:04:53 jlt nm-openvpn[11109]: /usr/libexec/nm-openvpn-service-openvpn-helper tun0 1500 1542 XX.XX.XX.XX XX.XX.XX.XX init
Oct 11 21:04:53 jlt nm-openvpn[11109]: Initialization Sequence Completed
Oct 11 21:04:55 jlt NetworkManager[541]: <info> No IPv6 configuration
Oct 11 21:04:55 jlt NetworkManager[541]: <info> (tun0): link connected
Oct 11 21:04:55 jlt NetworkManager[541]: <error> [1381518294.907722] [platform/nm-linux-platform.c:1109] add_object(): Netlink error: Unspecific failure
Oct 11 21:04:55 jlt NetworkManager[541]: <warn> VPN connection 'XXXXXXXX' did not receive valid IP config information.
Oct 11 21:04:55 jlt NetworkManager[541]: refresh_object: assertion 'kernel_object' failed
Oct 11 21:04:55 jlt NetworkManager[541]: <error> [1381518294.936827] [platform/nm-linux-platform.c:1142] delete_object(): Netlink error: No such device
Oct 11 21:04:55 jlt nm-openvpn[11109]: SIGTERM[hard,] received, process exiting
Oct 11 21:04:55 jlt avahi-daemon[2523]: Withdrawing workstation service for tun0.
Oct 11 21:04:55 jlt NetworkManager[541]: <warn> (tun0): failed to get device's ifindex
Oct 11 21:04:55 jlt systemd-udevd: specified group 'input' unknown
Oct 11 21:04:55 jlt NetworkManager: ** Message: Terminated openvpn daemon with PID 11109.
Oct 11 21:04:59 jlt NetworkManager[541]: <info> VPN service 'openvpn' disappeared

the problem depend of missing IPv6 configuration on server side?

Best Regards
Comment 3 Jirka Klimes 2013-10-17 03:16:59 EDT

*** This bug has been marked as a duplicate of bug 1018317 ***

Note You need to log in before you can comment on or make changes to this bug.