Bug 1016885 - log what is happening when undoing things after a failed install/upgrade
log what is happening when undoing things after a failed install/upgrade
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Installer (Show other bugs)
JON 3.2
Unspecified Unspecified
medium Severity medium
: ER04
: JON 3.2.0
Assigned To: John Mazzitelli
Mike Foley
:
Depends On:
Blocks: 1012435
  Show dependency treegraph
 
Reported: 2013-10-08 16:58 EDT by John Mazzitelli
Modified: 2014-01-02 15:37 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
install_db-error (238.64 KB, image/png)
2013-11-11 07:45 EST, Armine Hovsepyan
no flags Details
storage-node-installed-error (257.24 KB, image/png)
2013-11-11 07:45 EST, Armine Hovsepyan
no flags Details
upgrade-storageDataDir-permission-error (214.67 KB, image/png)
2013-11-11 07:46 EST, Armine Hovsepyan
no flags Details

  None (edit)
Description John Mazzitelli 2013-10-08 16:58:35 EDT
When an install or upgrade failed, we should log messages as the undo-tasks are executed so people can see what the installer is doing when it backs out any changes and removes remnants from the failed install/upgrade.
Comment 1 John Mazzitelli 2013-10-08 16:59:38 EDT
this should go in JON 3.2 since it will help debug install issues
Comment 2 John Mazzitelli 2013-10-08 17:15:48 EDT
git commit to master: 79402bc
Comment 3 John Mazzitelli 2013-10-18 11:26:47 EDT
fyi: this is going to be a hard one to cherry pick I think - because one of the classes looks to be drastically changed.
Comment 4 Simeon Pinder 2013-10-24 00:09:47 EDT
Moving to ON_QA for testing in the next build.
Comment 5 Armine Hovsepyan 2013-11-11 07:45:18 EST
Created attachment 822385 [details]
install_db-error
Comment 6 Armine Hovsepyan 2013-11-11 07:45:43 EST
Created attachment 822386 [details]
storage-node-installed-error
Comment 7 Armine Hovsepyan 2013-11-11 07:46:25 EST
Created attachment 822387 [details]
upgrade-storageDataDir-permission-error
Comment 8 Armine Hovsepyan 2013-11-11 07:48:26 EST
verified with the following cases:
* installing jon when no db exists
* upgrading jon with no access to storage root dir
* upgrading jon having already installed/upgraded same version

screen-shots attached

please assign back to me if risky scenario is missing

Note You need to log in before you can comment on or make changes to this bug.