Bug 101690 - can't install headless system (firstboot starts)
can't install headless system (firstboot starts)
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: firstboot (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-05 12:24 EDT by david d zuhn
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-05 15:44:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description david d zuhn 2003-08-05 12:24:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
I'm trying to install Severn onto a headless server.  I've used the vnc
installation option, and when I boot the system, it's in run level 5, the
firstboot service starts, and I'm dead in the water.

I'd like the ability to configure the system to boot into run level 3,
without X.  

If the firstboot functionality is considered essential, please think about
starting a VNC server at startup when a system has no local X display
capability.   I will happily do a 'vncviewer -via hostname :1' in order to get
into the machine using the root password.   

(Okay, I'm not completely DITW.  I can ssh into the machine, edit inittab to put
me into run level 3, reboot the machine, and then proceed from there).  But if I
didn't have ssh installed...




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install severn on a headless machine
2. reboot after install

    

Actual Results:  The system init scripts will run, until firstboot starts.  Then
no further progress is made, and I cannot finish booting the machine.

Expected Results:  I'd like to be able to specify (at installation time) that
any subsystem that relies on X not run, or at least not attempt to run on the
"head" of a headless system.  Then I can log into the machine, perform my system
configurations, and start use.

Additional info:
Comment 1 Brent Fox 2003-08-14 20:28:16 EDT
What type of installation class did you pick (server, workstation, custom) ?
Comment 2 david d zuhn 2003-08-15 12:51:13 EDT
I don't recall offhand, but I suspect it was a custom installation.
Comment 3 Brent Fox 2003-08-15 14:48:23 EDT
Ok, so in custom or server installation, there's a screen near the end of the
installation that allows you to pick whether you want graphical or text bootup.
 If you pick text bootup, you'll boot into runlevel 3 and skip firstboot
altogether.  So if you've got a headless machine, that's the setting you want to
pick.
Comment 4 Brent Fox 2003-09-22 15:53:10 EDT
Closing since I think that giving the user the choice of using text or GUI
startup in the installer should solve this problem.
Comment 5 david d zuhn 2003-10-29 10:35:37 EST
I just did a server install of Fedora Core test3 (severn3).  I did not get a
screen asking for GUI vs. text startup.  So I still get a system installed that
boots into firstboot.



Comment 6 Brent Fox 2004-01-05 15:44:19 EST
I have added a text mode interface to firstboot for Fedora Core 2. 
Please reopen this bug report if you still see this bug in Fedora Core
2 when it is released (probably in April).

Note You need to log in before you can comment on or make changes to this bug.