Bug 1016925 - BTRFSError: 11
BTRFSError: 11
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:a69fb8261f558d3d67ede437a83...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 19:44 EDT by Chris Murphy
Modified: 2015-01-20 12:41 EST (History)
12 users (show)

See Also:
Fixed In Version: python-blivet-0.28-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-01-20 12:41:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (1.29 MB, text/plain)
2013-10-08 19:44 EDT, Chris Murphy
no flags Details
File: anaconda.log (13.57 KB, text/plain)
2013-10-08 19:44 EDT, Chris Murphy
no flags Details
File: environ (509 bytes, text/plain)
2013-10-08 19:44 EDT, Chris Murphy
no flags Details
File: journalctl (887.59 KB, text/plain)
2013-10-08 19:44 EDT, Chris Murphy
no flags Details
File: lsblk_output (3.53 KB, text/plain)
2013-10-08 19:44 EDT, Chris Murphy
no flags Details
File: nmcli_dev_list (4.40 KB, text/plain)
2013-10-08 19:44 EDT, Chris Murphy
no flags Details
File: os_info (291 bytes, text/plain)
2013-10-08 19:44 EDT, Chris Murphy
no flags Details
File: program.log (40.46 KB, text/plain)
2013-10-08 19:44 EDT, Chris Murphy
no flags Details
File: storage.log (340.07 KB, text/plain)
2013-10-08 19:45 EDT, Chris Murphy
no flags Details
File: ifcfg.log (650 bytes, text/plain)
2013-10-08 19:45 EDT, Chris Murphy
no flags Details

  None (edit)
Description Chris Murphy 2013-10-08 19:44:16 EDT
Description of problem:
Guided partitioning, reclaim space with LVM default, deleting existing btrfs, swap, and Mac HFS+ EFI System partitions. Crash after Begin Installation.

Version-Release number of selected component:
anaconda-20.22-1.fc20.x86_64

The following was filed automatically by anaconda:
anaconda 20.22-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/devicelibs/btrfs.py", line 45, in btrfs
    raise BTRFSError(ret)
  File "/usr/lib/python2.7/site-packages/blivet/devicelibs/btrfs.py", line 93, in delete_subvolume
    return btrfs(args)
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 4518, in _destroy
    btrfs.delete_subvolume(mountpoint, self.name)
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 822, in destroy
    self._destroy()
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 318, in execute
    self.device.destroy()
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 237, in processActions
    action.execute()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 310, in doIt
    self.devicetree.processActions()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 169, in turnOnFilesystems
    storage.doIt()
  File "/tmp/updates/pyanaconda/install.py", line 142, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/tmp/updates/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
BTRFSError: 11

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   BOOT_IMAGE=/syslinux/vmlinuz0 root=live:UUID=A55C-7A63 rw rd.live.image overlay=UUID=A55C-7A63 noop updates=http://bcl.fedorapeople.org/updates/1010495.img
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.3-301.fc20.x86_64
other involved packages: python-blivet-0.22-1.fc20.noarch, python-libs-2.7.5-7.fc20.x86_64
product:        Fedora
release:        Fedora release 20 (Heisenbug)
type:           anaconda
version:        20

Potential duplicate: bug 1003430
Comment 1 Chris Murphy 2013-10-08 19:44:26 EDT
Created attachment 809595 [details]
File: anaconda-tb
Comment 2 Chris Murphy 2013-10-08 19:44:30 EDT
Created attachment 809596 [details]
File: anaconda.log
Comment 3 Chris Murphy 2013-10-08 19:44:34 EDT
Created attachment 809597 [details]
File: environ
Comment 4 Chris Murphy 2013-10-08 19:44:41 EDT
Created attachment 809598 [details]
File: journalctl
Comment 5 Chris Murphy 2013-10-08 19:44:46 EDT
Created attachment 809599 [details]
File: lsblk_output
Comment 6 Chris Murphy 2013-10-08 19:44:50 EDT
Created attachment 809600 [details]
File: nmcli_dev_list
Comment 7 Chris Murphy 2013-10-08 19:44:54 EDT
Created attachment 809601 [details]
File: os_info
Comment 8 Chris Murphy 2013-10-08 19:44:58 EDT
Created attachment 809602 [details]
File: program.log
Comment 9 Chris Murphy 2013-10-08 19:45:03 EDT
Created attachment 809603 [details]
File: storage.log
Comment 10 Chris Murphy 2013-10-08 19:45:07 EDT
Created attachment 809604 [details]
File: ifcfg.log
Comment 11 Chris Murphy 2013-10-08 20:18:18 EDT
So far this isn't reproducible.
Comment 12 Chris Murphy 2013-10-08 20:23:33 EDT
The live environment may not be "clean". Prior to the install I was trying to move an existing subvol into a new subvol, and kept getting kernel backlash. So I created a new btrfs file system and subvolumes with CLI, and had the same results. Then decided to launch anaconda to try an installation.

So it may be an edge case.
Comment 13 Chris Murphy 2013-10-08 21:01:10 EDT
HUH, this is weird:
19:39:23,948 INFO program: Running... btrfs subvol delete /tmp/btrfs-tmp.15r1tf6L/subvol2
19:39:23,964 INFO program: ERROR: cannot delete '/tmp/btrfs-tmp.15r1tf6L/subvol2' - Directory not empty
19:39:23,964 INFO program: Delete subvolume '/tmp/btrfs-tmp.15r1tf6L/subvol2'
19:39:23,964 DEBUG program: Return code: 11

Why is anaconda trying to delete subvolumes for a btrfs volume I've told Guided Partitioning to delete via Reclaim Space?

This is aside from why btrfs was unable to delete the subvolume.
Comment 14 Chris Murphy 2013-10-09 00:19:47 EDT
This bug is btrfs on one disk partition, and two subvolumes named subvol1 and subvol2.

Might be related to bug 1016959, which is btrfs with two subvols on LVM, using the same name.

Weird, because I've had subvolumes root, boot, home with many other installations, and they are blown away by anaconda with a reinstall just fine. So either this is a regression in anaconda 20.22-1 or maybe it's the name of the subvolumes?
Comment 15 Sudhir Khanger 2013-11-17 04:16:26 EST
Anaconda crashes as soon as you enter root password.

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-x86_64-20-Be rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.11.6-301.fc20.x86_64
other involved packages: python-libs-2.7.5-8.fc20.x86_64, python-blivet-0.23.4-1.fc20.noarch
package:        anaconda-20.25.6-1.fc20.x86_64
packaging.log:  
product:        Fedora
reason:         BTRFSError: 11
release:        Fedora release 20 (Heisenbug)
version:        20
Comment 16 David Lehman 2013-11-21 10:21:27 EST
Updates image available for testing (against 20-TC2):

  http://dlehman.fedorapeople.org/updates/updates-1121.0.img

It should add warning text when removing a btrfs volume that contains subvolumes and prevent this bug.
Comment 17 Chris Murphy 2013-11-21 19:42:14 EST
With Fedora live desktop TC2 and the updates.img applied, anaconda crashes on launch. Abrt refuses to upload its files, but I've saved the contents of the ccpp folder if any of those are useful let me know.

Note You need to log in before you can comment on or make changes to this bug.