Bug 1016941 - Cannot bring up preferences screen for Intelligent PinYin
Cannot bring up preferences screen for Intelligent PinYin
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus-libpinyin (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peng Wu
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 21:56 EDT by Ed Greshko
Modified: 2013-10-17 21:01 EDT (History)
6 users (show)

See Also:
Fixed In Version: ibus-libpinyin-1.6.91-5.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-15 02:28:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Step 1 of 3 (1.84 MB, image/png)
2013-10-09 01:48 EDT, Ed Greshko
no flags Details
Step 2 of 3 (1.65 MB, image/png)
2013-10-09 01:51 EDT, Ed Greshko
no flags Details
Step 3 of 3 (1.02 MB, image/png)
2013-10-09 01:52 EDT, Ed Greshko
no flags Details
Japanese works as expected (1.48 MB, image/png)
2013-10-09 03:13 EDT, Ed Greshko
no flags Details

  None (edit)
Description Ed Greshko 2013-10-08 21:56:33 EDT
Description of problem: Clicking on "Preferences" for Intelligent PinYin or Intelligent Bopomofo does not popup a dialog box


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Select ibus as the input method
2. Add Chinese - Intelligent Pinyin as an input method
3. Highlight the method and click on "Preferences"

Actual results:  Nothing happens


Expected results:  A "Preferences" dialog box should pop up to configure the input method.


Additional info:
Comment 1 Ed Greshko 2013-10-08 21:58:11 EDT
This is with KDE as the DM.
Comment 2 fujiwara 2013-10-09 01:30:16 EDT
I cannot reproduce your problem.
Would you attach the screenshot in #3 of the reproducible steps?

I'm not sure about KDE apps but 'gnome-screenshot -i' is available to take the screenshot.
Comment 3 Ed Greshko 2013-10-09 01:48:46 EDT
Created attachment 809667 [details]
Step 1 of 3

Right Click on Keyboard Icon in Systray and select "Preferences"
Comment 4 Ed Greshko 2013-10-09 01:51:05 EDT
Created attachment 809668 [details]
Step 2 of 3

Go to "Input Method" tab.  Highlight PinYin.  Click on "Preferences".  Nothing Happens....
Comment 5 Ed Greshko 2013-10-09 01:52:10 EDT
Created attachment 809669 [details]
Step 3 of 3

This is what is expected.  F19 system.
Comment 6 Ed Greshko 2013-10-09 01:56:20 EDT
FWIW, selecting Japanese and Preferences does bring up a Preferences dialog.
Comment 7 fujiwara 2013-10-09 02:56:53 EDT
(In reply to Ed Greshko from comment #5)
> Created attachment 809669 [details]
> Step 3 of 3
> 
> This is what is expected.  F19 system.

Oops, you hide the ibus-setup dialog by pinyin dialog.
Could you attached the screenshot in f20 again? which is failed to open pinyin dialog.
I'd like to see what is focused on ibus-setup but I don't need to see the pinyin dialog in the screenshot.
I cannot reproduce your problem in f20 KDE.

Do you use the latest ibus and ibus-libpinyin?

% rpm -q ibus ibus-libpinyin
ibus-1.5.4-2.fc20.x86_64
ibus-libpinyin-1.6.91-4.fc20.x86_64
Comment 8 fujiwara 2013-10-09 03:02:22 EDT
OK, Comment #4 shows the result.
Please ignore my previous comment.
Comment 9 Ed Greshko 2013-10-09 03:10:30 EDT
OK....  

FWIW, I was not running ibus-libpinyin-1.6.91-4.fc20.x86_64.  I have since downloaded and installed it from koji and the problem still exists for me.

Right Comment #4 is a snapshot from a working F19 system after "Preferences" is clicked.
Comment 10 Ed Greshko 2013-10-09 03:13:08 EDT
Created attachment 809697 [details]
Japanese works as expected
Comment 11 fujiwara 2013-10-09 03:34:44 EDT
Do you see any warnings when you run 'ibus-setup' on konsole?

Also are you able to launch pinyin setup when you run '/usr/libexec/ibus-setup-libpinyin pinyin' on konsole?
Comment 12 Ed Greshko 2013-10-09 03:45:52 EDT
[egreshko@localhost ~]$ /usr/libexec/ibus-setup-libpinyin pinyin
Traceback (most recent call last):
  File "main2.py", line 33, in <module>
    from xdg import BaseDirectory
ImportError: No module named xdg
Comment 13 fujiwara 2013-10-09 04:21:15 EDT
(In reply to Ed Greshko from comment #12)
> [egreshko@localhost ~]$ /usr/libexec/ibus-setup-libpinyin pinyin
> Traceback (most recent call last):
>   File "main2.py", line 33, in <module>
>     from xdg import BaseDirectory
> ImportError: No module named xdg

Thanks.
The workaround is to install pyxdg.

Now ibus does not require pyxdg.
So ibus-libpinyin needs to depend on pyxdg or GLib gir:
https://github.com/ibus/ibus/commit/ecced4f45a46cb7557717b04e1ce1b284a397b8c

Transferring to ibus-libpinyin.
Comment 14 Ed Greshko 2013-10-09 04:23:55 EDT
Verified workaround....

Thanks
Comment 15 Peng Wu 2013-10-09 05:01:36 EDT
Patch for ibus-libpinyin to use GLib:
https://github.com/epico/ibus-libpinyin/commit/cf8ab7d8e76ed70c182c7588cfe1ebbce8e5174b
Comment 16 Fedora Update System 2013-10-14 01:08:50 EDT
ibus-libpinyin-1.6.91-5.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/FEDORA-2013-18513/ibus-libpinyin-1.6.91-5.fc20
Comment 17 Fedora Update System 2013-10-15 02:28:10 EDT
ibus-libpinyin-1.6.91-5.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Ed Greshko 2013-10-17 21:01:20 EDT
FYI, verified fix.

Note You need to log in before you can comment on or make changes to this bug.