Bug 1016983 - Some error messages are given out when executing "oo-diagnostics" on node
Some error messages are given out when executing "oo-diagnostics" on node
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Containers (Show other bugs)
2.0.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Brenton Leanhardt
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-09 01:55 EDT by Ma xiaoqiang
Modified: 2017-03-08 12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-16 04:11:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ma xiaoqiang 2013-10-09 01:55:23 EDT
Description of problem:
Some error messages that should not be show are given out when executing "oo-diagnostics" 

Version-Release number of selected component (if applicable):
puddle:[2.0/2013-10-08.1] 
http://buildvm-devops.usersys.redhat.com/puddle/build/OpenShiftEnterprise/2.0/2013-10-08.1

How reproducible:
always

Steps to Reproduce:
1.Run the following command on node
#oo-diagnostics


Actual results:
Output:
FAIL: test_mcollective_context
      Mcollectived is not running in the expected SELinux context, which
      may result in node execution failures. Please check that the correct
      context is set on /opt/rh/ruby193/root/usr/sbin/mcollectived and that the correct SELinux
      policies are loaded.
        Expected: system_r:openshift_initrc_t:s0-s0:c0.c1023
        Found: unconfined_r:unconfined_t:s0-s0:c0.c1023
unconfined_u:system_r:initrc_t:s0
unconfined_u:system_r:initrc_t:s0
unconfined_u:system_r:initrc_t:s0
unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023
unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023
unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023
unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023

# vim /usr/sbin/oo-diagnostics 
lines 1068-1071
1068     scl_root = @project_is[:enterprise] ? "/opt/rh/ruby193/root" : ""
1069     context = `ps -o label= $(pgrep -f 'ruby[^[:space:]]*[[:space:]]/usr/sbin/mcollectived([[:space:]]|$)')`.chomp.split ":"
1070     context.shift
1071     context = context.join ":"
In the line 1069, program got the wrong path,the correct path is "/opt/rh/ruby193/root/usr/sbin/mcollectived".


Expected results:
Don't show this error.


Additional info:
This problem didn't happen on ose-1.2.z
Comment 2 Peter Ruan 2013-10-15 16:35:26 EDT
with puddle from 2013-10-14, oo-diagnostic now returns 2 errors only.

INFO: checking that required services are running now
FAIL: test_services_enabled
      The following service(s) are not currently started:
        openshift-port-proxy
      These services are required for OpenShift functionality.

INFO: checking that required services are enabled at boot
FAIL: test_services_enabled
      The following service(s) are not started at boot time:
        openshift-port-proxy
      These services are required for OpenShift functionality.
      Please ensure that they start at boot.

INFO: running: test_node_quota_bug
INFO: testing for quota creation failure bug
INFO: running: test_vhost_servernames
INFO: checking for vhost interference problems
INFO: running: test_altered_package_owned_configs
/usr/sbin/oo-diagnostics: No such file or directory - updatedb
sh: locate: command not found
INFO: running: test_broken_httpd_version
INFO: running: test_usergroups_enabled
INFO: running: test_mcollective_context
INFO: running: test_mcollective_bad_facts
INFO: running: test_auth_conf_files
INFO: running: test_broker_certificate
WARN: test_broker_certificate
Using a self-signed certificate for the broker
INFO: running: test_abrt_addon_python
2 WARNINGS
Comment 3 Brenton Leanhardt 2013-11-06 15:36:19 EST
Right now the only failure is:

FAIL: test_services_enabled
      The following service(s) are not currently started:
        openshift-iptables-port-proxy
      These services are required for OpenShift functionality.

This is because the openshift-iptables-port-proxy status function was noop and I removed it. :)

I'll think about this and consider either removing this check or having it actually do something useful.
Comment 4 Johnny Liu 2013-11-07 00:25:42 EST
(In reply to Brenton Leanhardt from comment #3)
> Right now the only failure is:
> 
> FAIL: test_services_enabled
>       The following service(s) are not currently started:
>         openshift-iptables-port-proxy
>       These services are required for OpenShift functionality.
> 
> This is because the openshift-iptables-port-proxy status function was noop
> and I removed it. :)
> 
> I'll think about this and consider either removing this check or having it
> actually do something useful.

About openshift-iptables-port-proxy status function, I opened a bug against upstream - BZ#1027163.

I prefer to have oo-diagnotics do something useful, if upstream could add status function and make it do something useful, that would be perfect.

openshift-iptables-port-proxy service is used to configure iptables for scalable app, so I think it is important to use oo-diagnotics to check iptables rules for openshift.
Comment 7 openshift-github-bot 2013-11-07 18:41:47 EST
Commits pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/900ec76cb57fc997e4906d948ea62997c6efbc6b
Bug 1016983 - Adding a status method for oo-diagnostics

https://github.com/openshift/origin-server/commit/c58269f9fb539c91141dca9bdce2af80b52639b6
Bug 1016983 - Check for the nat file in oo-admin-ctl-iptables-port-proxy status

https://github.com/openshift/origin-server/commit/b11b9367a2e27887be75f2207188b31dc37bb80c
Bug 1016983 - improving the oo-admin-ctl-iptables-port-proxy status check

https://github.com/openshift/origin-server/commit/315cd181c9a3cfe0675d42c72ab58196b1314f17
Bug 1016983 - oo-admin-ctl-iptables-port-proxy status now checks the NAT table
Comment 8 Ma xiaoqiang 2013-11-07 20:55:45 EST
check on puddle[2.0/2013-11-07.2]
[root@node1 ~]# oo-diagnostics 
WARN: test_altered_package_owned_configs
           RPM package owned configuration files have been altered:
             /etc/ntp.conf.rpmnew

           Ensure any package-owned configuration files which have been
           altered are accurate. This may require a manual merge of
           your previous alterations. Once you are comfortable with the merge,
           remove the reported .rpm* configuration file (or you will continue
           to see this warning each time you run the diagnostic test).

1 WARNINGS
NO ERRORS

Note You need to log in before you can comment on or make changes to this bug.