Bug 1016985 - edit-node:using --list-plugins option to list Installed Plugins incorrectly
edit-node:using --list-plugins option to list Installed Plugins incorrectly
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-09 02:03 EDT by haiyang,dong
Modified: 2014-01-21 14:53 EST (History)
13 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-5.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 14:53:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description haiyang,dong 2013-10-09 02:03:03 EDT
Description of problem:
Using "edit-node --repo=edit-node.repo --install=ovirt-node-plugin-puppet-3.0.1-3.el6.noarch.rpm rhev-hypervisor6-6.5-20130930.0.auto665.el6.iso
" to install puppet plugin into rhev-h.
Then using  --list-plugins option to list Installed Plugins:
rhev-hypervisor6-6.5-20130930.0.auto665.puppet.el6.iso

Installed Plugins:

ovirt-node-plugin-puppet

cim.minimize

snmp.minimize

puppet.minimize

Setting SELinux Permissive During Yum Install
Returning SELinux To Enforcing

we can notice that it list Installed Plugins incorrectly. It should just list
ovirt-node-plugin-puppet. Didn't list "cim.minimize/snmp.minimize/puppet.minimize"
info.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.5-20130930.0.auto665.el6.iso	
ovirt-node-3.0.1-3.el6.noarch
ovirt-node-tools-3.0.1-3.el6.noarch.rpm


How reproducible:
100%

Steps to Reproduce:


Actual results:


Expected results:


Additional info:
Comment 4 haiyang,dong 2013-10-26 09:19:39 EDT
Test version:
rhevh-6.5-20131024.1.0.iso
ovirt-node-3.0.1-6.el6.noarch
ovirt-node-tools-3.0.1-6.el6.noarch

Using "edit-node --repo=edit-node.repo --install=ovirt-node-plugin-puppet-3.0.1-6.el6.noarch.rpm rhevh-6.5-20131024.1.0.iso
" to install puppet plugin into rhev-h.

Then using  --list-plugins option to list Installed Plugins:
[root@dhcp-11-127 home]# edit-node --list-plugins rhevh-6.5-20131024.1.puppet.0.iso
rhevh-6.5-20131024.1.puppet.0.iso

Installed Plugins:

ovirt-node-plugin-puppet

Setting SELinux Permissive During Yum Install
Returning SELinux To Enforcing

we can notice that it only list Installed Plugins:
ovirt-node-plugin-puppet

so this bug has been fixed, change it into "VERIFIED".
Comment 6 Cheryn Tan 2013-11-07 19:24:29 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 9 errata-xmlrpc 2014-01-21 14:53:23 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.