Bug 101699 - rpm hung while adding package from cdrom
Summary: rpm hung while adding package from cdrom
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 9
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-05 18:16 UTC by Jun
Modified: 2007-04-18 16:56 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2003-08-21 17:58:56 UTC


Attachments (Terms of Use)

Description Jun 2003-08-05 18:16:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
I have redhat 9. rpm seemed to work ok until I tried to install addition package
from cdrom after upgrading. The add/remove package from window just hung after I
tried to add some package. Later, I tried to rpm -ivh each individual rpms
directly from cdrom, it just hung forever. I have to kill the job by pid. Then
rpm will not work at all unless I reboot the machine. Right after a fresh
reboot, rpm works again. I can cp the rpm to local disk, and rpm -ivh. But
whenever, I have a failed rpm try, rpm will stop working. Please tell me how I
can fix it. It is quite troublesome as I need to add a few additional packages
right now.

Thank you

Version-Release number of selected component (if applicable):
rpm-4.2-0.69

How reproducible:
Always

Steps to Reproduce:
1. rpm -ivh /mnt/cdrom1/RedHat/RPM/xxx.rpm
2. rpm hung
3. rpm -q rpm will hung too
    

Actual Results:  rpm will stop working unless I reboot the machine.

Expected Results:  rpm work correctly

Additional info:

I have SONY cd r/w (CRX220A1) on /mnt/cdrom1. By the way, right after rpm hung,
the /mnt/cdrom1 was kept busy until I kill the hunging rpm. Could it
be something related to the cdrom?

Comment 1 Jeff Johnson 2003-08-19 12:52:57 UTC
If you killed rpm using "kill -9" (or by other extraordinary
intervention), then you *must* remove stale locks by doing
    rm -f /var/lib/rpm/__db*
Does that fix?

Comment 2 Jun 2003-08-19 17:03:24 UTC
If the rpm is killed by 9, it worked again. But It DOES NOT FIX the problem. The
problem is:

cannot use rpm -ivh /mnt/cdrom1/RPMS/xxx.rpm
or
package add/delete utility does not work any more.

Please help.

Jun

Comment 3 Jeff Johnson 2003-08-20 14:48:26 UTC
This is quite possibly a cdrom or media error, not rpm, problem then.

Try installing package from /tmp. If that "works", then get your cdrom
or media fixed.

If you can't install from /tmp, then do
    rm -f /var/lib/rpm/__db*
and try again.

If above still doesn't install from /tmp, reopen this bug.

Comment 4 Jun 2003-08-20 22:05:24 UTC
As I said in the original report, I could copy the individual *.rpm to local
disk and rpm -ivh from local disk. The cdrom seemed to work fine as well, as I
could access it to get the *.rpm from cdrom.

However, I could not rpm -ivh /mnt/cdrom1/.../*.rpm. It looks like rpm has
trouble to access cdrom. The other evidence is that if I tried to use add/remove
package utility, it just hung. I figure that utility was running rpm to access
cdrom by default, and there is no way to change that default as far as I can see.

So, if this is not what you can solve, please direct me to the right place for a
solution. Right now, I can not use rpm to access cdrom.

Thank you for your response.


Jun

Comment 5 Jeff Johnson 2003-08-21 13:54:22 UTC
rpm does not know anything special about cdrom's, only opens
files, etc. If a command "works" on local storage, but not
on cdrom, then the difference is the cdrom.

You can try kernel, but you need to first try different
pieces of media and different cdrom's to rule out the
possibility of media problems and flakey hardware.

Comment 6 Jun 2003-08-21 16:38:31 UTC
First, Let me restate the problem if you have not fully understand it.

Under redhat 9, the cdrom and the installation disk are both GOOD. Nautilus has 
not problem to access cdrom and the same installation disk. Cdrom and the same 
disk can be accessed from the commandline. The problem ONLY occurs when the rpm 
tries to access a rpm package file on the same installation disk. If the file is 
copied from the cdrom to the local disk (by means of commandline copying tool or 
Nautilus, which means the cdrom and the installation disk are just fine!!!), rpm 
works like a chime. That only leads to one conclution: rpm CANNOT access cdrom. 
If you say "media problems and flakey hardware", then the media only has problem 
with rpm, and the hardware is flakey only when rpm tries to access it. Please 
help me to make sense of it.

Thank you.



Comment 7 Jeff Johnson 2003-08-21 17:58:56 UTC
I have helped you make sense of your problem by
    a) showing that rpm "works" on local storage, not on cdrom.
    b) suggesting that you vary the media and/or the drive to
    see whether that has an effect on your problem.
    c) suggesting that you seek support from the appropriate facilty.

Look, rpm is known to work on thousands of systems with cdroms
every day. That tells me (perhaps you?) that there is something different
on your system, not a bug with rpm.

Now go away and fix your problem. Bugzilla reports against rpm are not
going to get you a fix.


Comment 8 Jun 2003-08-21 20:41:52 UTC
Woa, response like this does come back quick.

Comment 9 Jun 2003-08-21 20:46:28 UTC
That's odd. Usually, developers are quick to response to the problems, and they
are usually hands-on persons and very knowledgeable. They know how to fix
problems. If they don't, they will direct you to a right place.

You don't seem to be a hands-on person, and not even a professional. Too bad,
you cannot fix the problem. You do not even understand the problem. And the way
you handle the problem is very unprofessional. I'm very sorry for you.

Thank you for your time anyway.  And Good luck to your career.

Jun


Note You need to log in before you can comment on or make changes to this bug.