Bug 10170 - automount daemon hang
automount daemon hang
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-14 13:53 EST by dliebson
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-16 18:05:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dliebson 2000-03-14 13:53:13 EST
Automount daemon hangs when multiple processes attempt
to simultaneously access the same nonexistant, automounted
filesystem.

perl -e 'fork; foreach(0..100){print "$$ $_\n";stat("/foo/bar");}'
will hang, where /foo has an associated map of the form
* -rw,rsize=8192,wsize=8192,noquota,bg,hard,intr,retrans=6 foo:/foo/&
and foo:/foo/bar is not exported.
Comment 1 Nalin Dahyabhai 2000-03-16 08:24:59 EST
Please upgrade to the latest version of autofs (3.1.4-3) from Raw Hide
(ftp://ftp.redhat.com/pub/rawhide/i386/RedHat/RPMS/), which may already
have fixed the problem (6.0 shipped with autofs 3.1.3).

However, it may be a kernel problem.  If you can use 'ps' to find the
PID of the hung automount process, try running "strace -p <PID>" to see
if it's hung waiting on the kernel or something else.
Comment 2 dliebson 2000-03-16 11:13:59 EST
Autofs 3.1.4 seems to have the the same problem.

PS shows two automount daemon processes for the mountpoint.
One is the parent process, and seems to be ok.  The second
process is a child, and is hung in a call to mkdir.
Comment 3 Nalin Dahyabhai 2000-03-16 17:13:59 EST
Then I suspect a race condition in the kernel.  Looks like it's in
fs/autofs/root.c somewhere.  Reassigning to the kernel package.

You may want to re-post that last part to the autofs mailing list at
autofs@linux.kernel.org, because this looks like a non-distribution-
specific problem to me.
Comment 4 Alan Cox 2000-09-16 18:04:59 EDT
A race in the kernel was indeed fixed - I suspect the 6.2 or 6.2 errata kernel
will be solid
Comment 5 Brent Fox 2002-06-05 11:57:48 EDT
Closing due to old age.

Note You need to log in before you can comment on or make changes to this bug.