Bug 1017007 - glusterd crash seen when volume operations are performed simultaneously on the same node, and one fails.
glusterd crash seen when volume operations are performed simultaneously on th...
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Bug Updates Notification Mailing List
Shruti Sampat
: ZStream
Depends On:
  Show dependency treegraph
Reported: 2013-10-09 02:56 EDT by Shruti Sampat
Modified: 2013-11-27 10:41 EST (History)
10 users (show)

See Also:
Fixed In Version: glusterfs-
Doc Type: Bug Fix
Doc Text:
Previously, due to locking issues in glusterd management deamon, glusterd crashed when two volume operations were executed simultaneously on the same node. Now, with this update this issue has been fixed.
Story Points: ---
Clone Of:
Last Closed: 2013-11-27 10:41:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
glusterd logs (1.01 MB, text/x-log)
2013-10-09 02:56 EDT, Shruti Sampat
no flags Details
core dump (262.53 KB, application/x-xz)
2013-10-09 03:11 EDT, Shruti Sampat
no flags Details

  None (edit)
Description Shruti Sampat 2013-10-09 02:56:42 EDT
Created attachment 809691 [details]
glusterd logs

Description of problem:
When volume operations like volume status, start and stop are executed simultaneously on the same machine, and one of them fails, a glusterd crash is seen.

Find attached glusterd logs and the core.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Run gluster volume status command on the node from a terminal multiple times.
2. On another terminal run volume operations like volume start and stop multiple times.

Actual results:
One of the operations fails and glusterd crashes.

Expected results:
glusterd should not crash.

Additional info:
Comment 1 Shruti Sampat 2013-10-09 03:11:05 EDT
Created attachment 809696 [details]
core dump
Comment 3 Prasanth 2013-10-09 08:14:50 EDT
glusterd crash is seen every often even without executing many operations in parallel. See below:

[2013-10-09 12:11:02.523379] E [glusterd-utils.c:149:glusterd_lock] 0-management: Unable to get lock for uuid: 50e87872-7d0c-4210-860e-41aabf41e79a, lock held by: 894e1ea3-8e38-4d2e-89e0-10fab0e9830b
[2013-10-09 12:11:02.523404] E [glusterd-syncop.c:1202:gd_sync_task_begin] 0-management: Unable to acquire lock
pending frames:
frame : type(0) op(0)

patchset: git://git.gluster.com/glusterfs.git
signal received: 11
time of crash: 2013-10-09 12:11:02configuration details:
argp 1
backtrace 1
dlfcn 1
fdatasync 1
libpthread 1
llistxattr 1
setfsid 1
spinlock 1
epoll.h 1
xattr.h 1
st_atim.tv_nsec 1
package-string: glusterfs
Comment 4 Kaushal 2013-10-10 08:10:01 EDT
This has been fixed by patch https://code.engineering.redhat.com/gerrit/13857 done for bug-1016971.
Comment 5 Shruti Sampat 2013-10-18 05:30:30 EDT
Verified as fixed in glusterfs Executed multiple volume operations in parallel. glusterd crash not seen.
Comment 7 errata-xmlrpc 2013-11-27 10:41:45 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.