Bug 1017010 - Unable to heal subscription with error [Errno 13] Permission denied: in rhsm.log
Unable to heal subscription with error [Errno 13] Permission denied: in rhsm...
Status: CLOSED DUPLICATE of bug 1000301
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
John Sefler
:
Depends On:
Blocks: rhsm-rhel70
  Show dependency treegraph
 
Reported: 2013-10-09 03:04 EDT by spandey
Modified: 2015-04-23 19:57 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-30 10:59:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description spandey 2013-10-09 03:04:15 EDT
Description of problem:


Version-Release number of selected component (if applicable):


Prerequisites:
Rhel7 with following subscription-manager rpm 
 subscription-manager-migration-data-2.0.4-1.git.0.6bebf6f.el7.noarch
subscription-manager-gui-1.10.3-1.git.1.4b7116f.el7.x86_64
subscription-manager-firstboot-1.10.3-1.git.1.4b7116f.el7.x86_64
subscription-manager-migration-1.10.3-1.git.1.4b7116f.el7.x86_64
subscription-manager-1.10.3-1.git.1.4b7116f.el7.x86_64

Steps to Repro : 
Register client to candlepin with product cert (100000000000002.pem)
set healing frequency for 1 min 

Expected result : 
After 1 min product should be in subscribed state .

Actual Result : 
healing is not getting completed with following message in rhsm.log file 

2013-10-09 23:20:59,873 [DEBUG] rhsmcertd-worker @connection.py:441 - Making request: GET /candlepin/consumers/da72931a-cf12-4240-8be0-a530343b1d59/certificates?serials=7516207693589626410
2013-10-09 23:20:59,928 [DEBUG] rhsmcertd-worker @connection.py:460 - Response status: 200
2013-10-09 23:20:59,932 [ERROR] rhsmcertd-worker @certlib.py:387 - [Errno 13] Permission denied: '/etc/pki/entitlement/7516207693589626410-key.pem'
Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/certlib.py", line 384, in install
    br.write(key, cert)
  File "/usr/share/rhsm/subscription_manager/certdirectory.py", line 308, in write
    key.write(key_path)
  File "/usr/lib64/python2.7/site-packages/rhsm/certificate.py", line 574, in write
    f = open(pem_path, 'w')
IOError: [Errno 13] Permission denied: '/etc/pki/entitlement/7516207693589626410-key.pem'
2013-10-09 23:20:59,934 [ERROR] rhsmcertd-worker @certlib.py:391 - Bundle not loaded:


error pastebin 

http://pastebin.test.redhat.com/169008
Comment 2 Carter Kozak 2013-10-30 10:59:49 EDT
Selinux is blocking us from writing to /etc/pki/entitlement and /etc/yum.repos.d/redhat.repo

There's an open bug to get that fixed.

*** This bug has been marked as a duplicate of bug 1000301 ***

Note You need to log in before you can comment on or make changes to this bug.