Bug 101702 - Mozilla built with GTK 2 has its bookmark paste function disabled.
Mozilla built with GTK 2 has its bookmark paste function disabled.
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: mozilla (Show other bugs)
1.0
All Linux
high Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
Ben Levenson
http://bugzilla.mozilla.org/show_bug....
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-05 16:06 EDT by Hans Deragon
Modified: 2007-03-27 00:08 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-09 13:20:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans Deragon 2003-08-05 16:06:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
From Mozilla's bugzilla:  http://bugzilla.mozilla.org/show_bug.cgi?id=209496

---->
Dahlqvist) wrote:

This bug is only present when you build a GTK2-enabled Mozilla Firebird - I have
verified that it does not occur in the latest gtk1.2 nightly. In a GTK2 build
however, if you select a bookmark in the bookmark manager, select "Cut" from the
context menu or normal menu, and then try to paste it somewhere else, the
"Paste" menu entry is not enabled. Fortunately, "Undo" works, so you can get
your bookmark back.
<-----

I, Hans Deragon, confirm that this problem also occurs on Mozilla 1.4 built with
GTK 2.

Version-Release number of selected component (if applicable):
1.4

How reproducible:
Always

Steps to Reproduce:
1) Get a GTK2-enabled Mozilla
2) Enter Manage Bookmarks and select a bookmark entry.
3) Choose Edit->Cut from the menu.
4) Move to where you want to paste the entry and open the Edit menu.

Actual Results:  Paste menu item remains grayed out.  Cannot paste.

Expected Results:  Paste menu item should be enabled when bookmark clipboard is
full.

Additional info:

I initially set the severity to high, because its an important feature that is
missing within the browser.
Comment 1 Hans Deragon 2003-08-06 12:31:04 EDT
Changed severity from ¨high¨ to ¨normal¨ and Priority from ¨normal¨ to ¨high¨
following Nils Philippsen's suggestion in rhl-beta-list mailing list.
Comment 2 Hans Deragon 2003-10-02 12:55:54 EDT
Looks like this issue has been resolved by Mozilla.  See
http://bugzilla.mozilla.org/show_bug.cgi?id=209496

Still, we should not close this bug until someone tested it on Fedora.
Comment 3 Christopher Blizzard 2003-10-09 13:20:28 EDT
This is fixed in 1.4.1-6.

Note You need to log in before you can comment on or make changes to this bug.