Bug 1017038 - SELinux is preventing /usr/lib64/thunderbird/thunderbird from using the 'ptrace' accesses on a process.
SELinux is preventing /usr/lib64/thunderbird/thunderbird from using the 'ptra...
Status: CLOSED DUPLICATE of bug 1086684
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:ad3a1c173f39c83096a061c9bc7...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-09 04:05 EDT by cyrushmh
Modified: 2014-04-14 02:48 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-14 02:48:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cyrushmh 2013-10-09 04:05:43 EDT
Description of problem:
SELinux is preventing /usr/lib64/thunderbird/thunderbird from using the 'ptrace' accesses on a process.

*****  Plugin catchall_boolean (89.3 confidence) suggests  *******************

If 您要 deny any process from ptracing or debugging any other processes.
Then 您必须启用 'deny_ptrace' 布尔值告知 SELinux 此情况。
您可以阅读 'unconfined_selinux' 手册页面来了解详情。
Do
setsebool -P deny_ptrace 0

*****  Plugin catchall (11.6 confidence) suggests  ***************************

If 您确定应默认允许 thunderbird ptrace 标记为 unconfined_t 的进程。
Then 您应该将这个情况作为 bug 报告。
您可以生成本地策略模块允许这个访问。
Do
请执行以下命令此时允许这个访问:
# grep thunderbird /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
                              023
Target Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
                              023
Target Objects                 [ process ]
Source                        thunderbird
Source Path                   /usr/lib64/thunderbird/thunderbird
Port                          <未知>
Host                          (removed)
Source RPM Packages           thunderbird-24.0-3.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-74.8.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.11.3-201.fc19.x86_64 #1 SMP Thu
                              Oct 3 00:47:03 UTC 2013 x86_64 x86_64
Alert Count                   2
First Seen                    2013-10-09 16:04:05 CST
Last Seen                     2013-10-09 16:04:05 CST
Local ID                      eefb87f2-7d47-4444-bf48-284c9540b1a2

Raw Audit Messages
type=AVC msg=audit(1381305845.202:1337): avc:  denied  { ptrace } for  pid=21034 comm="thunderbird" scontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=process


type=SYSCALL msg=audit(1381305845.202:1337): arch=x86_64 syscall=ptrace success=no exit=EACCES a0=10 a1=4f9e a2=0 a3=0 items=0 ppid=20348 pid=21034 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=1 tty=pts5 comm=thunderbird exe=/usr/lib64/thunderbird/thunderbird subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 key=(null)

Hash: thunderbird,unconfined_t,unconfined_t,process,ptrace

Additional info:
reporter:       libreport-2.1.7
hashmarkername: setroubleshoot
kernel:         3.11.3-201.fc19.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2014-04-14 02:48:52 EDT

*** This bug has been marked as a duplicate of bug 1086684 ***

Note You need to log in before you can comment on or make changes to this bug.