This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 101704 - kernel panic with shared memory graphic cards
kernel panic with shared memory graphic cards
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: John Dennis
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-05 16:27 EDT by Florian Brand
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 19:21:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/messages (117.47 KB, text/plain)
2003-08-05 16:37 EDT, Florian Brand
no flags Details

  None (edit)
Description Florian Brand 2003-08-05 16:27:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030709

Description of problem:
On a Dell Latitude 640 w/ Radeon 7500 (512M RAM) the kernel (boot and i686)
panics while accessing high memory. 
During Install, the Kernel Panic happens immediatly after "running /sbin/loader".

After install, irreproducible errors happen after boot with similar messages.

Current workaround is to use a mem=480M paramenter at install and boot.


Version-Release number of selected component (if applicable):
kernel-2.4.21-1.1931.2.349.2.2.ent

How reproducible:
Always

Steps to Reproduce:
1. Boot Linux
2. wait for panic :)

    

Actual Results:  "invalid kernel-mode pagefault 0! "

Expected Results:  no kernel panic?

Additional info:
Comment 1 Florian Brand 2003-08-05 16:37:31 EDT
Created attachment 93415 [details]
/var/log/messages

today's /var/log/messages
notice the problem doesn't occur when the system is started with mem=480M
Comment 2 Florian Brand 2003-08-05 16:42:55 EDT
just forgot: I did check for fauly memory with memtest86. No problems found.
Comment 3 Arjan van de Ven 2003-08-05 16:45:35 EDT
we've had a problem with this for a long time
somehow it doesn't happen with the installed kernel usually, is that the case
for you ?
Comment 4 Matt Wilson 2003-09-10 19:10:03 EDT
Florian, does this still happen?
Comment 5 Ernie Petrides 2004-04-08 18:21:26 EDT
Hello, Florian.  Is there still a problem with a more recent
RHEL 3 kernel (such as U1 -- 2.4.21-9.EL)?  Thanks.  -ernie
Comment 7 Ernie Petrides 2005-10-05 19:21:13 EDT
Closing due to lack of response.
Comment 8 Florian Brand 2005-10-06 03:22:13 EDT
(In reply to comment #7)
> Closing due to lack of response.

Sorry. Somehow I didn't recieve the comments prior to the 'bug closed' message.
The problem disappeared w/ more recent kernels.

Cheers
Florian

Note You need to log in before you can comment on or make changes to this bug.