Bug 1017104 - Could not use new password login after upgrade
Could not use new password login after upgrade
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
: Regression
Depends On:
Blocks: 1017490
  Show dependency treegraph
 
Reported: 2013-10-09 05:21 EDT by Guohua Ouyang
Modified: 2014-01-21 14:53 EST (History)
15 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-4.el6
Doc Type: Bug Fix
Doc Text:
--no tech note required
Story Points: ---
Clone Of:
: 1017490 (view as bug list)
Environment:
Last Closed: 2014-01-21 14:53:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20052 None None None Never

  None (edit)
Description Guohua Ouyang 2013-10-09 05:21:30 EDT
Description of problem:
Upgrade from 6.4 to 6.5, set new password on TUI. But could not use this password to login after reboot, the old one works.


Version-Release number of selected component (if applicable):
Rhev-hypervisor6-6.5-20130930.0.auto665

How reproducible:
100%

Steps to Reproduce:
1. Install rhevh 6.4
2. Upgrade to 6.5 via TUI.
3. Set new password.
4. Login with the new password.

Actual results:
Could not login with the new password, but the old can.

Expected results:
Login with new password successful.

Additional info:
Comment 4 cshao 2013-10-11 04:13:53 EDT
I am also found other two related issues form TUI upgrade password page.

1. The indication "You have not provided a new password, current admin password will be used" always show even if user provideed a new password.

2. Need pop-up warning info for indicate user when input a wrong current password.

Thanks!
Comment 5 Fabian Deutsch 2013-10-11 06:46:59 EDT
(In reply to shaochen from comment #4)
> I am also found other two related issues form TUI upgrade password page.
> 
> 1. The indication "You have not provided a new password, current admin
> password will be used" always show even if user provideed a new password.
> 
> 2. Need pop-up warning info for indicate user when input a wrong current
> password.

Hey Chen,

could you please open two separate bug reports for this issues. Otherwise they might get lost.
Comment 6 cshao 2013-10-12 03:01:57 EDT
(In reply to Fabian Deutsch from comment #5)
> (In reply to shaochen from comment #4)
> > I am also found other two related issues form TUI upgrade password page.
> > 
> > 1. The indication "You have not provided a new password, current admin
> > password will be used" always show even if user provideed a new password.
> > 
> > 2. Need pop-up warning info for indicate user when input a wrong current
> > password.

Hypervisor can pop-up warning info actually, just a little slower. So please ignore this.

> 
> Hey Chen,
> 
> could you please open two separate bug reports for this issues. Otherwise
> they might get lost.

OK,the new bug is here, bug 1018448.
Thanks!
Comment 10 Cheryn Tan 2013-11-07 19:32:44 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 12 errata-xmlrpc 2014-01-21 14:53:33 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.