Bug 1017109 - Error: print() on closed filehandle
Error: print() on closed filehandle
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: logwatch (Show other bugs)
6.4
x86_64 Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Jan Synacek
BaseOS QE - Apps
: Patch
Depends On:
Blocks: 1082014
  Show dependency treegraph
 
Reported: 2013-10-09 05:30 EDT by pb+red-hat
Modified: 2015-10-12 09:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1082014 (view as bug list)
Environment:
Last Closed: 2015-10-12 09:55:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix bug (529 bytes, patch)
2013-10-09 05:30 EDT, pb+red-hat
no flags Details | Diff

  None (edit)
Description pb+red-hat 2013-10-09 05:30:36 EDT
Created attachment 809814 [details]
Patch to fix bug

Description of problem:

After setting the following options in the logwatch.conf

SplitHosts = yes
MultiEmail = yes

The following error message is printed multiple times to stderr but the mails send look ok.

print() on closed filehandle OUTFILE at /usr/sbin/logwatch line 1321.


Version-Release number of selected component (if applicable):

7.3.6-49


How reproducible:

Tested on different hosts with the same result.


Steps to Reproduce:
1. Use a centralized syslog server
2. Set the specified config options in the logwatch config
3. Run logwatch


Actual results:

Displays error messages


Expected results:

No error messages


Additional info:

I have attached a patch that fixes the problem for me.
Comment 2 RHEL Product and Program Management 2013-10-13 19:01:36 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 3 Marcel Kolaja 2014-03-28 11:50:30 EDT
Please, see an alternative patch in bug #1082014 (which is the same bug for RHEL 5). That one takes a different approach, which is in line with the approach taken by upstream.

Note You need to log in before you can comment on or make changes to this bug.