Bug 1017124 - [fork][origin_ui_82] It doesn't work for --no-auto-deploy/--keep-deployments/--deployment-branch when creating app
[fork][origin_ui_82] It doesn't work for --no-auto-deploy/--keep-deployments/...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Fabiano Franz
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-09 05:47 EDT by Wei Sun
Modified: 2015-05-14 22:25 EDT (History)
2 users (show)

See Also:
Fixed In Version: fork_ami_origin_ui_82_897
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-17 09:34:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wei Sun 2013-10-09 05:47:26 EDT
Description of problem:
Create an app with  --no-auto-deploy/--keep-deployments/--deployment-branch options,but could not set these parameters successfully.  

Version-Release number of selected component (if applicable):
rhc-1.16.0 build from fork_ami_origin_ui_82_889
fork_ami_origin_ui_82_889

How reproducible:
Always

Steps to Reproduce:
1.Create an app with --no-auto-deploy/--keep-deployments/--deployment-branch options
2.Check deployment list
3.Change some code in local git repo and git push
4.Change if code is deployed. 

Actual results:
1.rhc app-create r9t ruby-1.9 --keep-deployments 4 --deployment-branch fork --no-auto-deploy

Your application 'r9t' is now available.

  URL:        http://r9t-wsunfor889.dev.rhcloud.com/
  SSH to:     5255212b6948fa563200006f@r9t-wsunfor889.dev.rhcloud.com
  Git remote: ssh://5255212b6948fa563200006f@r9t-wsunfor889.dev.rhcloud.com/~/git/r9t.git/
  Cloned to:  /home/wsun/test/dev/test/r9t

Run 'rhc show-app r9t' for more details about your app.

2.[wsun@dhcp-8-229 test]$ rhc deployment-list r9t
r9t @ http://r9t-wsunfor889.dev.rhcloud.com/ (uuid: 5255212b6948fa563200006f)
-----------------------------------------------------------------------------
  Deployment:        auto
  Keep Deployments:  1
  Deployment Type:   git
  Deployment Branch: master

Deployment ID 0e6f4df9 (active)
-------------------------------
  Ref:               master
  Sha1:              bfc489e
  Hot Deploy:        false
  Created At:        5:26 PM
  Force Clean Build: false
  Activations:       5:26 PM

4.code is deployed,and change takes effect .
Counting objects: 5, done.
Delta compression using up to 4 threads.
Compressing objects: 100% (3/3), done.
Writing objects: 100% (3/3), 285 bytes | 0 bytes/s, done.
Total 3 (delta 2), reused 0 (delta 0)
remote: Stopping Ruby cartridge
remote: [Wed Oct 09 05:35:33 2013] [warn] PassEnv variable SHELL was undefined
remote: [Wed Oct 09 05:35:33 2013] [warn] PassEnv variable USER was undefined
remote: [Wed Oct 09 05:35:33 2013] [warn] PassEnv variable LOGNAME was undefined
remote: Waiting for stop to finish
remote: Building git ref 'master', commit afece7f
remote: Building Ruby cartridge
remote: Preparing build for deployment
remote: Prepared deployment artifacts in /var/lib/openshift/5255212b6948fa563200006f/app-deployments/2013-10-09_05-35-35.578
remote: Deployment id is add3a785
remote: Activating deployment
remote: Result: success
remote: Activation status: success
remote: Deployment completed
To ssh://5255212b6948fa563200006f@r9t-wsunfor889.dev.rhcloud.com/~/git/r9t.git/
   bfc489e..afece7f  master -> master

Expected results:
These options should work well.

Additional info:
Comment 1 Fabiano Franz 2013-10-11 10:18:31 EDT
Create app with deployment options was pulled back from this feature. The user will need to create-app normally and then configure-app.
Comment 2 Xiaoli Tian 2013-10-12 06:18:53 EDT
Verified it on fork_ami_origin_ui_82_899, since it does not support set configuration for app while creating, configure-app works well after the app is created according to https://bugzilla.redhat.com/show_bug.cgi?id=1017517#c2

Note You need to log in before you can comment on or make changes to this bug.