Bug 1017137 - Gnome-software wrongly reports system is up to date
Gnome-software wrongly reports system is up to date
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-software (Show other bugs)
20
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-09 06:07 EDT by Zdenek Chmelar
Modified: 2014-03-21 05:27 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-21 05:27:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot from VM - 2 software tools report different status regarding to update availability (334.64 KB, image/png)
2013-10-09 06:07 EDT, Zdenek Chmelar
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 709742 None None None Never

  None (edit)
Description Zdenek Chmelar 2013-10-09 06:07:43 EDT
Created attachment 809837 [details]
screenshot from VM - 2 software tools report different status regarding to update availability

Description of problem:
Gnome-software shows 'Software is up to date' even if new packages are available and offered for an update in software update application.

Version-Release number of selected component (if applicable):
gnome-software-3.10.0-1.fc20.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Open Gnome-software
2. Jump on tab 'Updates'
3. User see message about upated system
4. Open software update tool and let it load - new packages are available for download and installation

Actual results:
Software tool shows updated system even if new packages are available for download

Expected results:
show list of packages available for installation, if applicable.

Additional info:
Available packages were listed in one of previous gnome-software versions (do not remember which version worked for the last time) but it does not work with actual version.
Please see screenshot for exact problem description
Comment 1 Ryan Lerch 2013-10-09 11:26:15 EDT
Thanks for your bug report Zdenek!

I have filed this upstream in the GNOME bug tracker:
https://bugzilla.gnome.org/show_bug.cgi?id=709742

I have also hit this issue before. However, when i hit it, gnome-software first reported that i had updates, but didn't actually do the updates, then when i went back into it, it informed me that the software was up-to-date.

Was the scenario you encountered similar?

Also, i think gnome-software checks for updates daily, are their updates showing up after waiting a day?

all in all though, i agree that this is a bug. :)
Comment 2 Zdenek Chmelar 2013-10-09 14:55:05 EDT
Hello Ryan

many thanks for such a fast reaction, I really appreciate your support!

Regarding your questions:
1) Honestly speaking, I didn't wait long time to let gnome-software reload repositories and make its daily check. So it is possible it would report new packages soon or later as well. I will test it.

2) In case of older version of gnome-software, I got the list of available updates immediately each time I clicked on 'Updates'. Gnome-software just performed short load (graphic circle of gradiently growing shadow dots) and then the list appeared. Well I didn't have the need to wait for its 'daily check' before.

3) My experience with updates installation under older version of gnome-software: Once the updates were available on tab 'Updates', I clicked on update button and confirmed pop-up message to reboot and update system. But no reboot (and installation) happened. Just Gnome session was stopped and system hanged (black screen).
After I forced system to reboot, gnome-software listed all available updates again after boot. New update attempt ended with hanged system again :)
I tested it on virtual machine so I wasn't sure if it was a problem of gnome-software or problem of too 'young' system.

I will keep the VM running for longer time now to see if gnome-software loads the updates.
Comment 3 Zdenek Chmelar 2014-03-21 05:27:12 EDT
Happy to see "reload" button in new Software. Herewith the report is not valid anymore. It is solved now.

gnome-software-3.11.91-2.fc20.x86_64

Note You need to log in before you can comment on or make changes to this bug.