Bug 1017140 - Deleting associated GPG keys, with products or repositories throws an error
Deleting associated GPG keys, with products or repositories throws an error
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Petr Chalupa
Kedar Bidarkar
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-09 06:18 EDT by Kedar Bidarkar
Modified: 2015-05-04 21:31 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-24 13:08:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error for associated gpg-keys (74.22 KB, image/png)
2013-10-09 06:18 EDT, Kedar Bidarkar
no flags Details

  None (edit)
Description Kedar Bidarkar 2013-10-09 06:18:06 EDT
Created attachment 809840 [details]
error for associated gpg-keys

Description of problem:

Deleting associated GPG keys with products/providers throws an error.

   

Version-Release number of selected component (if applicable):

Satellite-6.0.2-RHEL-6-20131007.0

How reproducible:
Deleting associated GPG keys with products/providers

Steps to Reproduce:
1. Create a gpg-key
2. associate a gpg-key with prods/providers
3. Try deleting the gpg-keys

Actual results:

throws the below error upon deletion of a gpg-key which is associated with product/provider

ERROR: update or delete on table "gpg_keys" violates foreign key constraint "products_gpg_key_id_fk" on table "products" DETAIL: Key (id)=(6) is still referenced from table "products". (PGError)
    Click here for more details.

Expected results:

Should allow deletion of gpg-keys.

Additional info:
Comment 1 RHEL Product and Program Management 2013-10-09 06:19:19 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 3 Kedar Bidarkar 2013-10-09 06:27:23 EDT
small correction: throws the below error upon deletion of a gpg-key which is associated with product or repositories.

that is 

1) gpg-key associated with product and then it's deletion

2) gpg-key assocaited with only repos and then it's deletion.

Also, another observation is that, upon navigating back to the gpg-keys page, the gpg-key is no longer visible in the left pane. But the UI does throw the above error.
Comment 4 Petr Chalupa 2013-10-11 10:40:56 EDT
fixed in 6a40eba9618409b004807484fdb0dcf1a6d9f60a
Comment 7 Corey Welton 2013-10-18 13:38:15 EDT
FWIW, this seems to be ok now but I will let Kedar verify.
Comment 8 Kedar Bidarkar 2013-10-21 06:59:04 EDT
Deleting the gpg-key associated with only product is successful.

Deleting the gpg-key associated with only repository is also successful.

Verified with Satellite-6.0.2-RHEL-6-20131016.0
Comment 9 Bryan Kearney 2014-04-24 13:08:14 EDT
This was verified and delivered with MDP2. Closing it out.

Note You need to log in before you can comment on or make changes to this bug.