Bug 1017141 - Please update imsettings to work with Cinnamon on F19, F20 and rawhide
Please update imsettings to work with Cinnamon on F19, F20 and rawhide
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: imsettings (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-09 06:18 EDT by Dan Mashal
Modified: 2013-10-22 23:39 EDT (History)
4 users (show)

See Also:
Fixed In Version: imsettings-1.6.6-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-15 02:43:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Mashal 2013-10-09 06:18:39 EDT
Hi,

As done for MATE please update imsettings to work with Cinnamon on Fedora 18,19,20 and rawhide.

Thanks a lot.
Comment 1 Mitch Davis 2013-10-09 06:27:02 EDT
I don't know if this is related, but I am unable to activate the Ibus IME or start the systray keyboard icon.
Comment 2 leigh scott 2013-10-09 06:27:34 EDT
Cinnamon no longer uses gnome gsettings schemas.

org.cinnamon.desktop.interface
Comment 3 Akira TAGOH 2013-10-09 23:17:07 EDT
Ah, that explains it all. will fix it soon.
Comment 4 Fedora Update System 2013-10-10 06:43:38 EDT
imsettings-1.6.5-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/imsettings-1.6.5-1.fc20
Comment 5 Akira TAGOH 2013-10-10 07:04:02 EDT
Hmm, I should ask before pushing the updates, does Cinnamon similarly support the ibus integration as the input source like GNOME3?
Comment 6 Fedora Update System 2013-10-10 08:05:44 EDT
imsettings-1.6.6-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/imsettings-1.6.6-1.fc19
Comment 7 Akira TAGOH 2013-10-10 08:06:49 EDT
should works now. please test.
Comment 8 Mitch Davis 2013-10-10 21:14:00 EDT
It works for me now.  I can now start the settings dialog, and I don't get the error message about schema mismatch.

Thanks for your help!
Comment 9 Fedora Update System 2013-10-10 22:35:28 EDT
Package imsettings-1.6.6-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing imsettings-1.6.6-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18833/imsettings-1.6.6-1.fc19
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2013-10-15 02:43:48 EDT
imsettings-1.6.6-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2013-10-22 23:39:42 EDT
imsettings-1.6.6-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.