Bug 1017159 - Cannot use BTRFS partition as root when already used
Cannot use BTRFS partition as root when already used
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
Unspecified Linux
unspecified Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-09 06:57 EDT by Taylor Smock
Modified: 2013-10-09 13:55 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-09 13:48:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Taylor Smock 2013-10-09 06:57:11 EDT
Description of problem:
When using a large BTRFS partition for multiple "virtual" partitions, Fedora cannot be installed to a subvolume (the installer does not give the option).


How reproducible:
Every time, once set up.

Steps to Reproduce:
1. Install Ubuntu with BTRFS (I have it under dm-crypt as well)
2. Add subvolumes (in my case, one for "data", one for "gentoo", one for "fedora". Ubuntu made "@home" and "@". "@" was renamed to "@ubuntu"
3. Attempt to install Fedora on the same BTRFS partition.

Actual results:
Installer wanted a "clean" root partition -- which is what the "fedora" subvolume was for.

Expected results:
Ability to select a subvolume for Fedora which is empty, or create a new subvolume for fedora when the root partition is BTRFS.

Additional info:
I do have Gentoo and Ubuntu on the same BTRFS partition -- the boot partitions are separate, so it should not be a limitation.
Comment 1 David Lehman 2013-10-09 13:20:48 EDT
You should be able to create a new subvolume in your existing btrfs filesystem to install fedora to.

You'll want to use custom partitioning (review/modify/&c). Create a new btrfs device with mountpoint '/'. If necessary, select your existing btrfs filesystem/volume from the dropdown menu on the lower-left of the "configure mountpoint" area.

"Empty" or "fresh" filesystems that already exist are not supported for use as the root filesystem, but a new subvolume that we create is acceptable.
Comment 2 Taylor Smock 2013-10-09 13:48:08 EDT
I figured it out (I was trying to specify a subvolume for the root filesystem, and was expecting the installer to do something like the following: 
    subvolume delete [name] ; subvolume create [name] 
instead of using Fedora's defaults, in order to avoid naming conflicts). I'll do what I did with Ubuntu, but it isn't always clear that "adding" a partition with BTRFS partitions will add a subvolume instead of wiping the entire partition.

Anyway,
Thanks.

Closing as NOTABUG. Because it isn't a bug.
Comment 3 David Lehman 2013-10-09 13:55:13 EDT
Yeah, you're right -- it can be a bit of a guessing game as far as what exactly will happen behind the scenes. In general, though, we won't ever remove/destroy devices without you asking us to do so -- that's the worst kind of surprise. Thanks for the report.

Note You need to log in before you can comment on or make changes to this bug.