Bug 1017179 - virt CPU hotplugging doesn't work
virt CPU hotplugging doesn't work
Status: CLOSED DUPLICATE of bug 1016318
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-09 07:40 EDT by Tadej Janež
Modified: 2013-11-10 10:46 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-10 10:46:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tadej Janež 2013-10-09 07:40:43 EDT
Description of problem:
I was following the instructions of the Virt CPU Hotplug test case for the F20 Virtualization test day.
Changing the number of CPUs to 2 and hitting Apply caused no effect in the guest, e.g. the output of 'ls -d /sys/devices/system/cpu/cpu[0-9]' remained '/sys/devices/system/cpu/cpu0'.
I confirmed beforehand that qemu-qa is running in the guest via 'ps axwww | grep qemu-qa'.

I played with virt-manager's CPU allocation a lot, since there is a bug in the display of the current CPU allocation (bug #1016318), but I couldn't get it to work.

Version-Release number of selected component (if applicable):
virt-manager-0.10.0-4.git79196cdf.fc20.noarch
Comment 1 Cole Robinson 2013-11-10 10:46:15 EST
Thanks for the report. I'm just going to dupe to the UI issue, since it's tough to correctly verify if libvirt is even being asked to do the correct thing when the UI is messed up. After that bug is fixed if you retested that would be greatly appreciated, but I suspect it was just misleading UI.

*** This bug has been marked as a duplicate of bug 1016318 ***

Note You need to log in before you can comment on or make changes to this bug.