Bug 1017196 - `service libvirt-guests status` may return 0 even if stopped
`service libvirt-guests status` may return 0 even if stopped
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Jiri Denemark
Virtualization Bugs
: ZStream
Depends On: 1011981
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-09 08:25 EDT by Chris Pelland
Modified: 2013-12-06 10:37 EST (History)
20 users (show)

See Also:
Fixed In Version: libvirt-0.10.2-18.el6_4.15
Doc Type: Bug Fix
Doc Text:
Whereas the status command of libvirt-guests init script returned "0" value when libvirt-guests service was stopped, LSB (Linux Standard Base) required a different value ("3") in such case. Consequently, other scripts relying on the return value could not distinguish whether the service was running or not. The libvirt-guests script has been fixed to conform with LSB and the "service libvirt-guests status" command now returns the correct value in the described scenario.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-13 05:29:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Pelland 2013-10-09 08:25:10 EDT
This bug has been copied from bug #1011981 and has been proposed
to be backported to 6.4 z-stream (EUS).
Comment 7 Xuesong Zhang 2013-11-06 02:02:13 EST
Test with the latest libvirt 6.4.z build libvirt-0.10.2-18.el6_4.15.x86_64, the return value is always 3 now, so this bug is verified.

Steps:
1. prepare one running guest.
# virsh start a
Domain a started

2. start the libvirt-guests service
# service libvirt-guests start
[root@xuzhangtest1 ~]# service libvirt-guests status
started

3. stop the libvirt-guests service
# service libvirt-guests stop

Running guests on default URI: a

Suspending guests on default URI...
Suspending a: ...
Suspending a: done

4. check the libvirt-guests service status
# service libvirt-guests status
stopped, with saved guests
[root@xuzhangtest1 ~]# echo $?
3




5. start the libvirt-guests service again.
]# service libvirt-guests start

Resuming guests on default URI...
Resuming guest a: done
[root@xuzhangtest1 ~]# service libvirt-guests status
started

6. destroy the guest.
# virsh list --all
 Id    Name                           State
----------------------------------------------------
 -     a                              shut off
7. stop the libvirt-guests service
# service libvirt-guests stop

Running guests on default URI: no running guests.

8. check the libvirt-guests status
[root@xuzhangtest1 ~]# service libvirt-guests status
stopped, with no saved guests
[root@xuzhangtest1 ~]# echo $?
3
Comment 9 errata-xmlrpc 2013-11-13 05:29:04 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1517.html

Note You need to log in before you can comment on or make changes to this bug.