Bug 1017201 - Invalid theme on VMs, doesn't show progress
Invalid theme on VMs, doesn't show progress
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fedup (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-09 08:35 EDT by Kamil Páral
Modified: 2013-12-13 00:35 EST (History)
2 users (show)

See Also:
Fixed In Version: fedup-dracut-0.8.0-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-13 00:35:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
blue line fedup theme during upgrade in a VM (1.20 KB, image/png)
2013-10-09 08:35 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2013-10-09 08:35:19 EDT
Created attachment 809885 [details]
blue line fedup theme during upgrade in a VM

Description of problem:
When I run fedup in a VM (qemu, spice, qxl), I see a blue line theme instead of the fedora icon + progress bar. The blue line theme doesn't indicate progress (maybe it does in some rough way, but it's really not visible).

When the fedup theme can't be started, please fall back to text output. Blue line theme is unusable, it looks like stuck.

Thanks.

Version-Release number of selected component (if applicable):
F20 Beta TC2
fedup 0.7.3-4.fc19
VM

How reproducible:
always

Steps to Reproduce:
1. install F19 in a VM (qemu, spice, qxl)
2. run fedup and reboot to upgrade mode
3. see blue line theme with no progress indication, it looks like stuck
Comment 1 Will Woods 2013-10-23 18:06:11 EDT
It's far more likely that your VM just doesn't have working KMS or fbdev. There doesn't seem to be a (working) modesetting driver in F20 for qxl.

Nevertheless, you should get text progress reporting so it doesn't look like things are stuck. This is now fixed in fedup-dracut:

  https://github.com/wgwoods/fedup-dracut/commit/3fcc51d
Comment 2 Fedora Update System 2013-12-11 17:12:42 EST
fedup-0.8.0-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/fedup-0.8.0-3.fc19
Comment 3 Fedora Update System 2013-12-11 17:15:35 EST
fedup-dracut-0.8.0-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/FEDORA-2013-22956/fedup-dracut-0.8.0-2.fc20
Comment 4 Fedora Update System 2013-12-12 11:32:10 EST
Package fedup-dracut-0.8.0-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fedup-dracut-0.8.0-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-22956/fedup-dracut-0.8.0-2.fc20
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-12-13 00:35:51 EST
fedup-dracut-0.8.0-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.