Bug 1017218 - Test upgrade of RHOS 3.0 mysql 5.1 databases to mariadb 5.5 database for RHOS 4.0
Test upgrade of RHOS 3.0 mysql 5.1 databases to mariadb 5.5 database for RHOS...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: distribution (Show other bugs)
3.0
Unspecified Unspecified
urgent Severity high
: rc
: 5.0 (RHEL 7)
Assigned To: Lars Kellogg-Stedman
Daniel Korn
: TestOnly
Depends On:
Blocks: 1005583 1060926
  Show dependency treegraph
 
Reported: 2013-10-09 08:58 EDT by Perry Myers
Modified: 2014-09-08 01:41 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1060926 (view as bug list)
Environment:
Last Closed: 2014-07-08 11:12:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Perry Myers 2013-10-09 08:58:33 EDT
RHOS 3.0 users relied on the mysql 5.1 database shipped in RHEL 6.4

RHOS 4.0 users will be using mariadb 5.5 which is available as part of the Red Hat Software Collections (RHSCL)

We need to make sure that migration path from RHOS 3.0/mysql5.1 to RHOS 4.0/mariadb5.5 is well documented and stable.

This bug is to track creation of a set of scripts/HOWTO on this migration (which should be offline)
Comment 3 Lars Kellogg-Stedman 2013-10-09 13:28:15 EDT
Upgrading MySQL 5.1 to MariaDB 5.5 on RHOS 3/RHEL 6.4 seems to work smoothly just following the instructions in the RHSCL docs for an in-place upgrade.

The only additional information necessary in a HOWTO is a note about shutting down all OpenStack services before the upgrade and starting them up afterwards.  I talked with pbrady briefly about adding a script to openstack-utils to make this easier, but right now it requires the local admin to both (a) which hosts comprise their openstack installation and (b) which services are active on each host.
Comment 4 Perry Myers 2013-10-09 13:49:35 EDT
(In reply to Lars Kellogg-Stedman from comment #3)
> Upgrading MySQL 5.1 to MariaDB 5.5 on RHOS 3/RHEL 6.4 seems to work smoothly
> just following the instructions in the RHSCL docs for an in-place upgrade.

Can you provide a link to that here for RHOS QE benefit?
 
> The only additional information necessary in a HOWTO is a note about
> shutting down all OpenStack services before the upgrade and starting them up
> afterwards.

This is a prerequisite for a RHOS 3.0 to 4.0 upgrade in general anyhow, so should be part of the normal procedure until we can close gaps around doing online/rolling ugprades upstream
Comment 5 Lars Kellogg-Stedman 2013-10-09 13:52:02 EDT
I was using Alan's link from comment #1 (which is correct other than the naming).
Comment 7 Lars Kellogg-Stedman 2014-05-30 15:08:43 EDT
Staring with RHEL6.5/RHEL-OSP4:

- Installed RHEL-OSP4 via 'packstack --allinone' (this is MySQL 5.1)
- Shutdown openstack services
- Shutdown mysql
- Add RDO Icehouse repository
- Uninstall mysql-server
- Install mariadb-galera-server (5.5.36-9)
- Start mysql-server
- Run mysql_upgrade
- Start openstack services

Everything works with nary an error in sight.
Comment 8 Ami Jeain 2014-06-12 07:44:43 EDT
testing per Lars comment#7.
Comment 9 Daniel Korn 2014-06-22 08:51:08 EDT
I've Deployed a working RHOS 4.0 (latest Havana release - 2014-05-22.1)

Then followed the steps from Lars's comment:
- Stopped all openstack services
- Stopped mysql
- Added Icehouse repository (latest - 2014-05-29.3) 
- Uninstalled mysql-server
- Run yum update
- Installed mariadb-galera-server
- Started mysql-server
- Run mysql_upgrade
- Started openstack services

Finally:
- Verified the environment is working correctly
- Created/deleted resources (Image, Instances, storage, etc.) without any problems
Comment 11 errata-xmlrpc 2014-07-08 11:12:29 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0845.html

Note You need to log in before you can comment on or make changes to this bug.