Bug 1017226 - Switching to edit mode doesn't work properly on tables with inline editing
Summary: Switching to edit mode doesn't work properly on tables with inline editing
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web Console
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ER7
: EAP 6.2.0
Assignee: Heiko Braun
QA Contact: Jakub Cechacek
Russell Dickenson
URL:
Whiteboard:
Depends On:
Blocks: 1021418
TreeView+ depends on / blocked
 
Reported: 2013-10-09 13:10 UTC by Jakub Cechacek
Modified: 2013-12-15 16:22 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-12-15 16:22:12 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker HAL-264 0 Major Resolved Resource adapter inline editing problems 2013-11-21 23:25:08 UTC

Description Jakub Cechacek 2013-10-09 13:10:01 UTC
Tables with inline value editing (such as Properties in add XA Datasource dialog) are not working properly. 

Steps to reporduce

1) Login to console 
2) navigate to Profile - Connector - Datasources - XA Datasources
3) Click add button and proceed to step 3 - property configuration 
4) click add button 
5) click into "name" cell 

expected result: cell content is replaced with input 
actual result: 


From user point of view it not possible to enter edit mode at first attempt or sometimes return back to read-only mode. From customer point of view this is mainly usability issue. However consequently our test automation is failing as it seems that the issue is somewhere in DOM manipulation.

Comment 2 JBoss JIRA Server 2013-10-10 13:14:25 UTC
Heiko Braun <ike.braun@googlemail.com> updated the status of jira HAL-264 to Resolved

Comment 3 Jakub Cechacek 2013-11-06 08:28:26 UTC
Verified 6.2.0.ER7


Note You need to log in before you can comment on or make changes to this bug.