Bug 1017264 - RTGov disabled when installing server+client together
RTGov disabled when installing server+client together
Status: CLOSED WONTFIX
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Build Process (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity medium
: ER4
: ---
Assigned To: Julian Coleman
Jiri Sedlacek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-09 10:06 EDT by Andrej Vano
Modified: 2015-08-02 19:45 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-18 07:38:03 EST
Type: Enhancement
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrej Vano 2013-10-09 10:06:20 EDT
Description of problem:
When installing RTGov client + server, the default setting is that the RTGov is disabled. This should be done when installing "server only" (currently not supported), because server wouldn't collect data on itself. 
If the client is installed too, the RTGov should be enabled after installation.

Version-Release number of selected component (if applicable):
6.0.0.ER4

How reproducible: 100%


Steps to Reproduce:
1. in the installation select rtgov client+server
2. after the installation is the rtgov disabled
standalone/configuration/overlord-rtgov.properties -> collectionEnabled=false

Actual results:


Expected results:


Additional info:
Comment 2 Gary Brown 2013-10-22 03:35:56 EDT
It has previously been agreed that rtgov activity event collection should be disabled by default upon installation, to avoid any performance impact on applications, unless the user explicitly wants to use rtgov, in which case they manually enable it.

Therefore, all installations of rtgov, whether client only or client+server should set collectionEnabled to false.

Note You need to log in before you can comment on or make changes to this bug.