Bug 1017304 - Policy sync quickstart fails when using clustered cache
Policy sync quickstart fails when using clustered cache
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: RT Governance (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity high
: ER7
: 6.0.0
Assigned To: Gary Brown
Jiri Pechanec
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-09 11:24 EDT by Gary Brown
Modified: 2014-07-02 05:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-06 10:26:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker RTGOV-292 Major Closed Policy sync quickstart fails with clustered cache 2014-08-25 17:25:36 EDT

  None (edit)
Description Gary Brown 2013-10-09 11:24:37 EDT
Description of problem:

When using the clustered cache configuration, with the standalone-full-ha.xml configuration, the following exception occurs:

Caused by: java.lang.RuntimeException: [Error: cm.lock("Principals", customer): Cannot create a transactional context without a valid Transaction instance.]
[Near : {... String customer=event.properti ....}]
             ^
[Line: 1, Column: 1]

The cache container configuration is:

            <cache-container name="rtgov" jndi-name="java:jboss/infinispan/container/rtgov" start="EAGER">
                <transport lock-timeout="60000"/>
                <replicated-cache name="Principals" mode="SYNC">
                    <locking isolation="REPEATABLE_READ"/>
                    <transaction mode="FULL_XA" locking="PESSIMISTIC"/>
                </replicated-cache>
            </cache-container>

and the overlord-rtgov.properties is updated to uncomment the infinispan.container property and point it to "java:jboss/infinispan/container/rtgov"

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Update standalone-full-ha.xml and overlord-rtgov.properties as above
2.Start the standalone-full-ha server
3.Deploy the ordermgmt, policy and sla quickstarts
4.Send example order

Actual results:


Expected results:


Additional info:
Comment 1 JBoss JIRA Server 2013-10-09 13:04:41 EDT
Gary Brown <gary@brownuk.com> updated the status of jira RTGOV-292 to Resolved
Comment 2 Jiri Pechanec 2014-01-07 07:12:04 EST
Verified in ER8
Comment 3 JBoss JIRA Server 2014-07-02 05:18:42 EDT
Gary Brown <gary@brownuk.com> updated the status of jira RTGOV-292 to Closed

Note You need to log in before you can comment on or make changes to this bug.