Bug 1017308 - RFE: virt-install: support network disk options (gluster, rbd, http)
RFE: virt-install: support network disk options (gluster, rbd, http)
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: virt-manager (Show other bugs)
unspecified
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Cole Robinson
SATHEESARAN
:
: 531420 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-09 11:32 EDT by SATHEESARAN
Modified: 2014-12-10 14:02 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-10 14:02:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description SATHEESARAN 2013-10-09 11:32:31 EDT
Description of problem:
QEMU now provides the efficient way to create images (raw,qcow2) on glusterfs volumes directly using libgfapi and not using fuse mount.
(e.g) qemu-img create gluster://gluster-server/vol-name/file1.img 30G
      qemu-img create gluster://gluster-server/vol-name/dir1/file1.img 30G

But there are no options currently available to make use of such an image available in glusterfs volume(using this qemu+glusterfs driver ), for the creation of VM

This bug is raised to add such an option

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
No option provided for making use of qemu+glusterfs driver, for the creation of VM

Expected results:
There should be an option to make use of qemu+glusterfs driver

Additional info:
qemu-system-x86_64 has option called "--file", which expects the argument in the form of, "gluster://<gluster-server-host>/<gluster-volume-name>/[<dirname>/]filename"

Note: directory name is optional
Comment 1 Daniel Berrange 2013-10-09 11:35:41 EDT
virt-manager does not want to ever run any qemu tools directly. This requires adding support for a gluster based storage pool in libvirt first.
Comment 2 Cole Robinson 2013-10-09 12:01:17 EDT
Well there's domain <disk> support for gluster volumes, right? I figured that's what the initial IRC query was about. But yes if you want virt-install to create a new volume and not just use an existing one, it will require libvirt patches as well.
Comment 3 Cole Robinson 2014-02-01 10:52:05 EST
Also, we should at least make sure virt-manager UI doesn't blow up or look awful when it sees a network disk
Comment 4 Cole Robinson 2014-02-01 15:55:27 EST
*** Bug 531420 has been marked as a duplicate of this bug. ***
Comment 5 Cole Robinson 2014-02-01 15:56:56 EST
Another bit, from the duped bug, is allowing HTTP cdrom installs. I don't think we should add an explicit new mode for it, but maybe we can make virt-install/virt-manager 'just work' if passed an HTTP iso path as CDROM media. Something to explicitly test at least.
Comment 6 Cole Robinson 2014-12-10 14:02:42 EST
Upstream virt-install supports:

--disk $URL

for gluster, http, etc. It should 'just work'. It also allows explicit building like:

--disk source_protocol=gluster,source_name=...,...

Note You need to log in before you can comment on or make changes to this bug.