Bug 1017310 - Configure Grinder when running on a CDS to log to it's own file.
Configure Grinder when running on a CDS to log to it's own file.
Status: CLOSED ERRATA
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: CDS (Show other bugs)
2.1.2
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 2.1.3
Assigned To: John Matthews
Ina Panova
:
Depends On:
Blocks: 1017410
  Show dependency treegraph
 
Reported: 2013-10-09 11:33 EDT by John Matthews
Modified: 2013-12-17 15:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
This update adds a way to control the logging output for a CDS, which helps with debugging. Users can now observe the log file to see grinder's behaviour. New logging options also provide fine grained control, logging for specific modules, and alter so certain modules' output saves to a different file or is disabled.
Story Points: ---
Clone Of:
: 1017410 (view as bug list)
Environment:
This update adds a way to control the logging output for a Content Delivery Server. The output from the log aids in debugging issues. The behavior of grinder can be viewed by looking at its log file. This gives fine grained control and allows for logging for specific modules. The log can be altered so certain modules go to a different file or can be disabled. This opens full control of logging configuration as allowed by Python's logger.
Last Closed: 2013-12-17 15:10:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Matthews 2013-10-09 11:33:39 EDT
Description of problem:

We would like to see Grinder writing to it's own log file on a CDS during sync.

The proposed change is to modify how the CDS configures the python logging and use a logging configuration file similar to what pulp-server does.
Comment 1 John Matthews 2013-10-09 11:40:56 EDT
Added a config entry to /etc/pulp/cds.conf to control what logging config file to load
   log_config_file = /etc/pulp/logging/cds.cfg

Introduced new logging configuration file:  /etc/pulp/logging/cds.cfg
   https://github.com/splice/pulp/blob/rhui/etc/pulp/logging/cds.cfg

To view the CDS logs, look at:
 /var/log/pulp-cds/pulp.log    <- Pulp specific (was gofer.log)
 /var/log/pulp-cds/grinder.log <- Grinder specific

Gofer log is still at:
  /var/log/gofer/agent.log


Associated commit:
https://github.com/splice/pulp/commit/438e944f22d35393497023fb07cce23e8e9bd366
Comment 2 Ina Panova 2013-11-07 10:40:01 EST
tested in pulp-0.0.263-40.el6_5.noarch

Move to Verified.
Comment 4 errata-xmlrpc 2013-12-17 15:10:41 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1854.html

Note You need to log in before you can comment on or make changes to this bug.