This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1017366 - rpm verify of tuned package fails
rpm verify of tuned package fails
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: tuned (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity urgent
: rc
: ---
Assigned To: Jaroslav Škarvada
Tereza Cerna
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-09 13:43 EDT by Hubert Kario
Modified: 2015-07-22 03:14 EDT (History)
6 users (show)

See Also:
Fixed In Version: tuned-0.2.19-15.el6
Doc Type: Bug Fix
Doc Text:
Previously, certain files from the tuned packages could be incorrectly considered to differ from the RPM database. As a consequence, RPM verification performed by running the "rpm -V tuned" command could fail and it could be indicated that the files were changed despite not being touched by the user. This update excludes several attributes, such as size, md5sum, and mtime, from the verification of the files, and RPM verification no longer fails.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-22 03:14:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hubert Kario 2013-10-09 13:43:17 EDT
Description of problem:
When verifying the package using rpm -V the verification fails

Version-Release number of selected component (if applicable):
tuned-0.2.19-11.el6.1.noarch
tuned-0.2.19-13.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. rpm -V tuned

Actual results:

for -11:
....L....  c /etc/ktune.d/tunedadm.conf
....L....  c /etc/sysconfig/ktune
S.5....T.  c /etc/tune-profiles/active-profile
....L....  c /etc/tuned.conf

for -13:
....L.... c /etc/sysconfig/ktune
S.5....T. c /etc/tune-profiles/active-profile
....L.... c /etc/tuned.conf

Expected results:
no errors

Additional info:
Comment 2 Jaroslav Škarvada 2013-10-10 04:25:30 EDT
(In reply to Hubert Kario from comment #0)
> for -11:
> ....L....  c /etc/ktune.d/tunedadm.conf
> ....L....  c /etc/sysconfig/ktune
> S.5....T.  c /etc/tune-profiles/active-profile
> ....L....  c /etc/tuned.conf
> 
> for -13:
> ....L.... c /etc/sysconfig/ktune
> S.5....T. c /etc/tune-profiles/active-profile
> ....L.... c /etc/tuned.conf
> 
I think there is no regression. It is caused by (non-optimal) design of the RHEL-6 tuned - it updates symlinks during profile change. So probably both versions behaves the same if same profile is selected. We can disable the check for the affected files.
Comment 3 Hubert Kario 2013-10-10 05:00:36 EDT
(In reply to Jaroslav Škarvada from comment #2)
> I think there is no regression. It is caused by (non-optimal) design of the
> RHEL-6 tuned - it updates symlinks during profile change. So probably both
> versions behaves the same if same profile is selected. We can disable the
> check for the affected files.

Yes, since the file are supposed to be changed, excluding them from the check would be good idea.
Comment 11 Tereza Cerna 2015-03-04 06:07:57 EST
==============================
Verified in version:
    tuned-0.2.19-15.el6.noarch
PASSED
==============================

# rpm -V tuned
# echo $?
0

==================================
Reproduced in version:
    tuned-0.2.19-13.el6_6.1.noarch
FAIL
==================================

# rpm -V tuned
....L....  c /etc/ktune.d/tunedadm.conf
....L....  c /etc/sysconfig/ktune
S.5....T.  c /etc/tune-profiles/active-profile
....L....  c /etc/tuned.conf
# echo $?
1
Comment 12 errata-xmlrpc 2015-07-22 03:14:51 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1376.html

Note You need to log in before you can comment on or make changes to this bug.