Bug 1017371 - Verification of openswan package fails
Verification of openswan package fails
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: openswan (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Paul Wouters
Ondrej Moriš
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-09 13:57 EDT by Hubert Kario
Modified: 2013-11-21 18:48 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 18:48:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hubert Kario 2013-10-09 13:57:10 EDT
Description of problem:
After installing nss and ca-certificates dependent errata, verification of openswan package using `rpm -V` fails.

Version-Release number of selected component (if applicable):
openswan-2.6.32-25.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. chmod 755 /etc/prelink.conf.d
2. yum install openswan
3. rpm -V openswan
4. ls -lha /etc/prelink.conf.d
5. chmod 755 /etc/prelink.conf.d
6. rpm -V openswan

Actual results:
[root@rhel6-64 ~]# rpm -V openswan
[root@rhel6-64 ~]# ls -lha /etc/prelink.conf.d/
total 20K
drwx------.   2 root root 4.0K Oct  9 19:55 .
drwxr-xr-x. 100 root root  12K Oct  9 19:55 ..
-rw-r--r--.   1 root root   23 Oct  2 23:51 openswan-fips.conf
[root@rhel6-64 ~]# chmod 755 /etc/prelink.conf.d/
[root@rhel6-64 ~]# rpm -V openswan
.M.......    /etc/prelink.conf.d

Expected results:
openswan should leave the directory mode alone or default to 755

Additional info:
Comment 6 errata-xmlrpc 2013-11-21 18:48:17 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1718.html

Note You need to log in before you can comment on or make changes to this bug.