Bug 1017373 - rpmdevtools install intrusive bash completion
rpmdevtools install intrusive bash completion
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpmlint (Show other bugs)
19
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-09 14:02 EDT by Pete Zaitcev
Modified: 2014-01-04 19:40 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-04 19:40:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pete Zaitcev 2013-10-09 14:02:27 EDT
Description of problem:

When rpmdevtools packge is installed, tab-expansion of filenames
is compromised. In particular, spec name cannot be expanded for
rpmlint.

Version-Release number of selected component (if applicable):

rpmdevtools-8.3-3.fc19.noarch

How reproducible:

Synchronoous but may depend on order of install in /etc/bash_completion.d

Steps to Reproduce:
1. yum install rpmdevtools rpmdiff
2. cd somewhere in Fedora git tree where you have a spec file foo.spec
3. rpmlint f<TAB>

Actual results:

Insane grinding of the disk for about a minute, maybe 90 seconds

Expected results:

foo.spec

Additional info:

I looked at /etc/bash_completion.d/rpmdevtools.bash-completion, but
could not understand a thing. Let's have its author figure it out.
Comment 1 Ville Skyttä 2013-10-10 08:08:21 EDT
rpmlint completion is in the rpmlint package, and rpmdevtools doesn't have a dependency on it.

If you want to override programmable rpmlint completion altogether, use Alt-/ instead of Tab. Or start completing the rpmlint specfile prefixing it with ./ so it won't trigger lookup of installed packages.

I've never seen anything like 90 seconds for this though. My 3 year old laptop (which OTOH has a SSD disk) does it in less than half a second.
Comment 2 Pete Zaitcev 2013-10-10 13:38:01 EDT
I filed this against rpmdevtools because in my testing it seemed that
removing rpmdevtools would resume normal completion. However, it seems
that perhaps I was wrong. When rpmlint alone is installed, completion
takes 11 seconds or so, which is much faster but still not ideal.

Note You need to log in before you can comment on or make changes to this bug.