Bug 1017413 - TTY login no longer works when disk is full
TTY login no longer works when disk is full
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: pam (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-09 16:15 EDT by Jonas Thiem
Modified: 2016-08-22 07:52 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-04 04:23:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonas Thiem 2013-10-09 16:15:34 EDT
Description of problem:
TTY login no longer works when disk is full (password prompt never shows up after entering the user name). This can be a problem when root access is required to remove the files, and there is no root shell open (or no user login at all). I haven't tested ssh, but I suppose it might be affected aswell.

The component I picked may be wrong, but I was refused the correct component name in #fedora because it was spontaneously decided this was "not a bug" and I should apparently be barred from filing it. While I agree the behaviour which is subject of this bug might be more of a design issue, it's still not ideal and I would certainly like to be allowed to file a bug report on it.

Version-Release number of selected component (if applicable):
3.11.1-200.fc19.x86_64

How reproducible:
I tested only once, at a later accidential disk fill I hit #1017408 and therefore I was a bit reluctant to try again with additional disk fills

Steps to Reproduce:
1. Fill disk
2. Go to TTY with ctrl+alt+F2
3. Attempt login

Actual results:
I can enter a username and press enter, but the password prompt never shows up. Eventually, the login expires.

Expected results:
Login works.

Additional info:
Comment 1 Josh Boyer 2013-10-09 16:37:07 EDT
If your disk is full and things need to write to the disk to log in, then I don't think there is much that can be done here.  At any rate, it isn't a kernel issue.  Moving to the distribution component.
Comment 2 Jonas Thiem 2013-10-09 17:17:14 EDT
I am wondering if there was a way login could be done anyway? (e.g. by storing whatever needs to be written - login logs I suppose - in memory?)

Also sorry for the #fedora remark, it doesn't belong here and it might or might not have been a misunderstanding. (it's on irc feedback now)
Comment 3 Bill Nottingham 2013-10-09 17:25:42 EDT
The login & getty programs come from util-linux, although the issue could lie elsewhere.
Comment 4 Jonas Thiem 2013-10-09 17:45:41 EDT
If this is related, sudo and su don't work either.
Comment 5 Tomas Mraz 2013-10-10 07:25:44 EDT
We would need a strace log of the login process to see where it is stuck.
Comment 6 Jonas Thiem 2013-10-10 08:37:48 EDT
Hmm I suppose I could see if I can reproduce it safely inside a virtual machine. I'm a bit reluctant with trying it on my laptop atm where I experienced this, since btrfs.

The agetty processes are the one I would need to attach strace to I suppose?
Comment 7 Karel Zak 2013-10-10 08:59:30 EDT
Yes, probably strace with -f (agetty asks for username, then exec login(1), the login process asks for password).

It's probably journald or audit problem.
Comment 8 Tomas Mraz 2014-01-13 05:58:07 EST
We need strace log to find out where the login process is stuck.
Comment 9 Jonas Thiem 2016-08-22 07:52:25 EDT
Clearing needinfo since this has been closed for years

Note You need to log in before you can comment on or make changes to this bug.