Bug 1017428 - multipathd does not start in dracut
multipathd does not start in dracut
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
20
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-09 16:53 EDT by Zbigniew Jędrzejewski-Szmek
Modified: 2013-11-06 12:48 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-06 12:48:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zbigniew Jędrzejewski-Szmek 2013-10-09 16:53:18 EDT
Description of problem:
Following test day instructions: https://fedoraproject.org/wiki/QA:Testcase_Virtualization_URL_Guest_Install, virt-install part

% sudo virt-install --name test-day-vm --ram 2048 \
        --disk path=/var/lib/libvirt/images/test-day-vm.img,size=10 \
        --location http://download.fedoraproject.org/pub/fedora/linux/development/20/x86_64/os/

When the image is booted, boot fails in dracut, with multipathd.service failing to start. Screenshot attached.

How reproducible:
Doing 'systemctl start multipathd' fails immediately every time ("Job for multipathd.service failed. See...").

Starting /usr/sbin/multipathd works fine.
Comment 1 Ben Marzinski 2013-10-10 13:02:15 EDT
Do you have an

/etc/multipath.conf

in your initramfs?  systemd won't start multipathd unless that file exists. The only other check is that the kernel cmdline doesn't include "nompath"

After you start and stop multipathd once, does

# systemctl start multipathd

then work?
Comment 2 Zbigniew Jędrzejewski-Szmek 2013-10-10 14:17:28 EDT
(In reply to Ben Marzinski from comment #1)
> Do you have an
> 
> /etc/multipath.conf
Yes:
$ cat /etc/multipath.conf
defaults {
   find_multipaths yes
   user_fiendly_names yes
}

> in your initramfs?  systemd won't start multipathd unless that file exists.
It starts fine by hand, so I don't think this file is a problem.

> The only other check is that the kernel cmdline doesn't include "nompath"
$ cat /proc/cmdline
method=http://download.fedoraproject.org/pub/fedora/linux/development/20/x86_64/os/

> After you start and stop multipathd once, does
> 
> # systemctl start multipathd
> 
> then work?
No.
Comment 3 Zbigniew Jędrzejewski-Szmek 2013-10-10 14:32:46 EDT
Oh, stupid, stupid me: it's ExecStartPre=/sbin/modprobe dm-multipath that's failing.

# /sbin/modprobe dm-multipath
# echo $?
1

Investigating further...
# uname -r
3.11.3-301.fc20.x86_64
# ls /lib/modules
3.11.2-301.fc20.x86_64

So, this is a mismatch between the initrd.img and the kernel.

Reassigning to virt-install.

I tried now again, and this time the downloaded initrd.img and kernel match one another. So this was probably just bad timing on my part, when virt-install downloaded from a partially updated mirror.
Comment 4 Cole Robinson 2013-11-06 12:48:14 EST
Yeah not sure there's anything to do about that in virt-install. I'm going to update the test cases to not point to download.fedoraproject.org, since that link does automagic mirror redirection, so you might end up fetching packages from different mirrors which may be in different states.

Note You need to log in before you can comment on or make changes to this bug.