Bug 1017434 - Compare Metrics Broken for Group Metrics
Compare Metrics Broken for Group Metrics
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: UI (Show other bugs)
JON 3.2
Unspecified Unspecified
high Severity urgent
: ER05
: JON 3.2.0
Assigned To: Mike Thompson
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-09 17:06 EDT by Mike Thompson
Modified: 2014-01-02 15:33 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-02 15:33:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
autogroup-compare (608.56 KB, image/png)
2013-11-07 10:41 EST, Armine Hovsepyan
no flags Details

  None (edit)
Description Mike Thompson 2013-10-09 17:06:33 EDT
Description of problem:
Compare metrics button pulls up 404 error for /resource/common/monitor/Visibility.do

Version-Release number of selected component (if applicable): 
3.2 ER03


How reproducible:
Always


Steps to Reproduce:
1. Click on autogroup such as CPU
2. click monitoring tab
3. click metrics subtab
4. Select a couple member resources 
5. Hit Compare button

Actual results:
Error message saying 404.


Expected results:
metrics comparison screen.

Additional Info:
This page is coming from portal.war so either the portal.war location naming changes or BZ 995541 - Removing AWT Threading related classes.
Comment 1 Mike Thompson 2013-10-24 17:23:35 EDT
This was due to the portal.war naming changes in BZ 1000065 (session shows signs of life during install).
 
This is fixed in master commit id: dee3ffc.

Cherry-picked to release/jon3.2.x as commit id: 43f068a
Comment 2 Simeon Pinder 2013-11-06 21:17:29 EST
Moving to ON_QA for test with new brew build.
Comment 3 Armine Hovsepyan 2013-11-07 10:40:48 EST
verified in er5

screen-shot attached (no control on compare page -> #951927)

thank you.
Comment 4 Armine Hovsepyan 2013-11-07 10:41:08 EST
Created attachment 821218 [details]
autogroup-compare

Note You need to log in before you can comment on or make changes to this bug.