Bug 1017449 - /etc/pulp/server.conf needs to be updated based on latest pulp
/etc/pulp/server.conf needs to be updated based on latest pulp
Status: CLOSED UPSTREAM
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: David Davis
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-09 18:39 EDT by Brad Buckingham
Modified: 2013-10-17 16:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-17 16:46:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brad Buckingham 2013-10-09 18:39:05 EDT
Description of problem:

While debugging an issue with syncing a pulp child node, we observed that the pulp configuration is representative of earlier versions of pulp.  As a result, we need to update the /etc/pulp/server.conf that gets installed to more accurately reflect the version of pulp being used and the needs of Satellite 6.

The following is the current state of the server.conf used by the installers:

katello-configure: https://github.com/Katello/katello-installer/blob/master/modules/pulp/templates/etc/pulp/server.conf.erb

node-installer: https://github.com/Katello/node-installer/blob/master/modules/pulp/templates/etc/pulp/server.conf.erb

The following is the current state of the server.conf provided by pulp:

https://github.com/pulp/pulp/blob/master/server/etc/pulp/server.conf

We need to compare the values from pulp with the values used by the installer and update accordingly.  For example, the initial issue that raised this BZ was that the *_timeout values have been updated by pulp (e.g. 30s:12h); however, the timeout we use is 10:600.  See additional notes below for input from Jeff on these.  With the current settings a child sync (which uses update_timeout) may timeout after 10 minutes.

Version-Release number of selected component (if applicable):
node-installer-0.0.15-2.el6sat.noarch
katello-configure-1.4.5-9.el6sat.noarch

How reproducible:
always

Steps to Reproduce:
1. install a Satellite server and run katello-configure
2. install a Satellite node and run node-install
3.

Actual results:
/etc/pulp/server.conf is contains old values

Expected results:
/etc/pulp/server.conf contains updated values

Additional info:

<jortel> I'd bump those timeouts using your own judgment.  the 1st number is how long the agent has to start actually running the request.  The 2nd is how long it has to complete it.  I'd make the 2nd number like 3d (3 days) or more and the 1st, like, 36h (36 hours).  The only down side is; the bigger the 1st setting, the longer it will take for the caller to get feedback that the agent is down.
Comment 1 RHEL Product and Program Management 2013-10-09 18:44:29 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 3 David Davis 2013-10-10 13:42:52 EDT
katello-installer PR

https://github.com/Katello/katello-installer/pull/55

node-installer PR

https://github.com/Katello/node-installer/pull/5
Comment 4 David Davis 2013-10-14 11:09:39 EDT
katello-installer SHA 568ba15f8e8bd097095867377b6b04b7134442ac

1017449: Update the pulp config


node-installer SHA 8221c71d79c5fb5799685602b796e43cc9e5acc5

1017449: Updating pulp server.conf
Comment 7 Mike McCune 2013-10-17 16:46:00 EDT
nothing to test specifically here.

Note You need to log in before you can comment on or make changes to this bug.