Bug 1017458 - Intermittent OptimisticLockException on set project validation options
Summary: Intermittent OptimisticLockException on set project validation options
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Zanata
Classification: Retired
Component: Component-Persistence
Version: 3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Sean Flanigan
QA Contact: Zanata-QA Mailling List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-10-09 23:43 UTC by Damian Jansen
Modified: 2015-07-31 01:14 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-31 01:14:27 UTC


Attachments (Terms of Use)
Test run log file (258.81 KB, text/plain)
2013-10-09 23:43 UTC, Damian Jansen
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1207575 0 unspecified CLOSED Zanata still creates MyISAM (not InnoDB) tables in some cases 2021-02-22 00:41:40 UTC

Internal Links: 1207575

Description Damian Jansen 2013-10-09 23:43:17 UTC
Created attachment 810206 [details]
Test run log file

Description of problem:
Sometimes selecting a validation option and pressing Update causes an exception.

Version-Release number of selected component (if applicable):
3.x

How reproducible:
Intermittent

Steps to Reproduce:
1. Sign in as admin
2. Go to project->version
3. Click Edit Version
4. Change a validation option
5. Press Update

Actual results:
In a small number of cases, StaleObjectStateException/OptimisticLockException occurs

Expected results:
No exception!

Additional info:
Attached log file

Comment 1 Damian Jansen 2014-07-28 05:57:44 UTC
Tested 3.5.0-SNAPSHOT (git-server-3.4.2-201-ge0afdde) - no longer an issue

Comment 2 Sean Flanigan 2015-04-17 03:44:19 UTC
I suspect this may have been caused by the accidental use of MyISAM for some tables.

Comment 3 Sean Flanigan 2015-04-17 06:38:30 UTC
On second thought, I have been seeing StaleObjectStateException in functional tests, which are probably not using MyISAM (MySQL 5.5.34 should default to InnoDB).  I think MyISAM problems must manifest differently.


org.zanata.feature.concurrentedit.ConcurrentAccessTest sometimes triggers these exceptions, especially if you run a few copies at once.

It's looking very much like a thread safety problem.  I'll see what I can do, at least for ConcurrentAccessTest.

Comment 4 Zanata Migrator 2015-07-31 01:14:27 UTC
Migrated; check JIRA for bug status: http://zanata.atlassian.net/browse/ZNTA-373


Note You need to log in before you can comment on or make changes to this bug.