Bug 1017477 - manpage for NFS(5) implies that local_lock is not supported in RHEL 6, when it is
manpage for NFS(5) implies that local_lock is not supported in RHEL 6, when i...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nfs-utils (Show other bugs)
6.4
All Linux
unspecified Severity low
: rc
: ---
Assigned To: Steve Dickson
Yin.JianHong
: ManPageChange
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-09 21:40 EDT by advax
Modified: 2014-10-14 00:32 EDT (History)
2 users (show)

See Also:
Fixed In Version: nfs-utils-1.2.3-47.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 00:32:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description advax 2013-10-09 21:40:15 EDT
The NFS(5) manpage states:

 local_lock=mechanism
       Specifies  whether to use local locking for any or both of the flock and
       the POSIX locking mechanisms.  mechanism  can  be  one  of  all,  flock,
       posix, or none.  This option is supported in kernels 2.6.37 and later.


It appears that this mechansim has been back-ported into the 2.6.32 kernel
in e.g. linux-2.6.32-220.el6/fs/nfs/super.c

So local_lock does in fact work in, I believe, all RHEL6 releases
Comment 2 Peter Schiffer 2014-02-04 12:19:14 EST
nfs(5) man page is part of the nfs-utils package
Comment 4 Yin.JianHong 2014-05-28 23:28:25 EDT
[root@dhcp12-241 nfs-utils-1.2.3]# man ./utils/mount/nfs.man | grep local_lock=mechanism -A 10
       local_lock=mechanism
                      Specifies  whether to use local locking for any or both of the flock and the POSIX locking mechanisms.  mechanism can be one of all, flock,
                      posix, or none.

                      The Linux NFS client provides a way to make locks local. This means, the applications can lock files, but such locks provide exclusion only
                      against other applications running on the same client. Remote applications are not affected by these locks.

                      If this option is not specified, or if none is specified, the client assumes that the locks are not local.

                      If all is specified, the client assumes that both flock and POSIX locks are local.
Comment 6 errata-xmlrpc 2014-10-14 00:32:03 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1407.html

Note You need to log in before you can comment on or make changes to this bug.