Bug 1017499 - bamf-0.5 is available
bamf-0.5 is available
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bamf (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
:
Depends On:
Blocks: plank
  Show dependency treegraph
 
Reported: 2013-10-09 23:41 EDT by Christopher Meng
Modified: 2014-02-14 03:51 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-14 03:45:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Christopher Meng 2013-10-09 23:41:32 EDT
Hi,

Please update it to the latest 0.5 version for rawhide to help build plank.

Thanks!
Comment 1 Christopher Meng 2013-11-08 10:08:25 EST
ping after a month.
Comment 2 Christopher Meng 2014-02-10 19:16:48 EST
Help this one ;)
Comment 3 Michel Alexandre Salim 2014-02-14 02:55:09 EST
Hi Christopher,

Apologies for the delay. The update is now almost ready, after swatting a couple of compile-warning-treated-as-error.

I'm double-checking a build failure on Rawhide -- looks like GCC is getting even stricter there (the last statement in a function produces a value, and the function is void, but there was no return statement -- and yet when GCC produces an error it claims there was a return):

http://kojipkgs.fedoraproject.org//work/tasks/9450/6529450/build.log

so for the moment, please use the test package in COPR for testing. I'll try reproducing the Rawhide issue in mock, and if necessary just hack a void return to make GCC happy:

http://copr.fedoraproject.org/coprs/salimma/bamf05/
Comment 4 Michel Alexandre Salim 2014-02-14 03:45:07 EST
Aha, turns out it's fixed in a post-release commit (and I was looking at trunk since I was working on a compile warning fix there). Now built for Rawhide.

Do you need an update for F20 as well? It's quite a major update and there are no longer separate GTK2 and GTK3 support, so I guess I'll keep the COPR repo up for F20 testing in case we want to do that.
Comment 5 Christopher Meng 2014-02-14 03:49:06 EST
I don't need it for f20. But you can build one and push in testing.

Plank doesn't depends on the latest version, but we can have a try(Be careful if you want to add buildroot override.)

Thank you!

Note You need to log in before you can comment on or make changes to this bug.