Bug 1017550 - Server returns HTTP response code 500 for WSDL url
Summary: Server returns HTTP response code 500 for WSDL url
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web Services
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ER7
: EAP 6.2.0
Assignee: Alessio Soldano
QA Contact: Rostislav Svoboda
Russell Dickenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-10-10 07:11 UTC by Petr Sakař
Modified: 2014-06-18 07:20 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
Cause: Consequence: Workaround (if any): Results:
Clone Of:
Environment:
Last Closed: 2013-12-15 16:15:36 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker JBWS-3717 0 Major Closed EndpointResolver implementations do not verify endpoint state before using endpoint 2016-03-08 13:51:29 UTC
Red Hat Issue Tracker JBWS-3719 0 Major Closed ServiceContainerEndpointRegistry#getRegisteredEndpoints() returns set containing null 2016-03-08 13:51:29 UTC

Description Petr Sakař 2013-10-10 07:11:34 UTC
Description of problem:

We can see intermittent failures of different tests with the following common symptoms:

Test is reading wsdl from server, failure cause is 
  Caused by: java.io.IOException: Server returned HTTP response code: 500 for URL: http://localhost:8080/anyname?wsdl
In server log we see following exception

ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[default-host].[/jaxrpc-samples-jsr109pojo-doc].[TestService]] (http-/127.0.0.1:8080-23) JBWEB000235: Allocate exception for servlet TestService: java.lang.NullPointerException
	at org.jboss.wsf.stack.jbws.WebAppResolver.query(WebAppResolver.java:58)
	at org.jboss.as.webservices.util.ServiceContainerEndpointRegistry.resolve(ServiceContainerEndpointRegistry.java:68)
	at org.jboss.wsf.stack.jbws.AbstractEndpointServlet.initEndpoint(AbstractEndpointServlet.java:149)
	at org.jboss.wsf.stack.jbws.AbstractEndpointServlet.initServiceEndpoint(AbstractEndpointServlet.java:126)
	at org.jboss.wsf.stack.jbws.AbstractEndpointServlet.init(AbstractEndpointServlet.java:74)
	at org.jboss.wsf.spi.deployment.WSFServlet.init(WSFServlet.java:57) [jbossws-spi-2.2.1.Final-redhat-1.jar:2.2.1.Final-redhat-1]
	at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1194) [jbossweb-7.2.2.Final-redhat-1.jar:7.2.2.Final-redhat-1]
	at org.apache.catalina.core.StandardWrapper.allocate(StandardWrapper.java:950) [jbossweb-7.2.2.Final-redhat-1.jar:7.2.2.Final-redhat-1]
	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:151) [jbossweb-7.2.2.Final-redhat-1.jar:7.2.2.Final-redhat-1]
	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:149) [jbossweb-7.2.2.Final-redhat-1.jar:7.2.2.Final-redhat-1]
	at org.jboss.as.web.security.SecurityContextAssociationValve.invoke(SecurityContextAssociationValve.java:169) [jboss-as-web-7.3.0.Final-redhat-8.jar:7.3.0.Final-redhat-8]
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:145) [jbossweb-7.2.2.Final-redhat-1.jar:7.2.2.Final-redhat-1]
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:97) [jbossweb-7.2.2.Final-redhat-1.jar:7.2.2.Final-redhat-1]
	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:102) [jbossweb-7.2.2.Final-redhat-1.jar:7.2.2.Final-redhat-1]
	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:336) [jbossweb-7.2.2.Final-redhat-1.jar:7.2.2.Final-redhat-1]
	at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:856) [jbossweb-7.2.2.Final-redhat-1.jar:7.2.2.Final-redhat-1]
	at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:653) [jbossweb-7.2.2.Final-redhat-1.jar:7.2.2.Final-redhat-1]
	at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:920) [jbossweb-7.2.2.Final-redhat-1.jar:7.2.2.Final-redhat-1]


Version-Release number of selected component (if applicable):
EAP 6.2.0.ER1-5

How reproducible:
intermittent

Additional info:
I would suspect thread safe related issues in class org.jboss.wsf.stack.jbws.WebAppResolver
I think fails test using deployment done after the exception is thrown

Comment 1 Alessio Soldano 2013-10-10 10:46:32 UTC
Upstream jira: https://issues.jboss.org/browse/JBWS-3717

Comment 3 Alessio Soldano 2013-10-21 07:45:25 UTC
As per Petr analysis, the actual reason for the problem here should be https://issues.jboss.org/browse/JBWS-3719

JBWS-3717 could also cause the same effect, but is most likely not the first culprit here.

Comment 5 Alessio Soldano 2013-10-21 13:32:32 UTC
https://github.com/jbossas/jboss-eap/pull/576

Comment 7 JBoss JIRA Server 2013-10-21 14:11:06 UTC
Alessio Soldano <asoldano@redhat.com> updated the status of jira JBWS-3719 to Closed

Comment 8 JBoss JIRA Server 2013-10-21 14:11:08 UTC
Alessio Soldano <asoldano@redhat.com> updated the status of jira JBWS-3717 to Closed

Comment 11 Petr Sakař 2013-11-05 14:12:47 UTC
verified - I've check test failures with symptoms described are not present on EAP 6.2.0.ER7

Comment 12 Scott Mumford 2013-12-01 23:56:02 UTC
I can see from comments in this and attached JIRAs that the server error was being caused by incorrect endpoints being returned. But I'm not able to ascertain how this was corrected.

With EAP 6.2 GA looming, I'm requesting a draft release note text (including layman's description of the problem and the fix) be supplied in the Doc Text field above.

Any and all help is appreciated, Alessio.

Comment 13 Alessio Soldano 2013-12-02 14:05:17 UTC
Scott,
honestly I believe we don't need any release note here. This issue was a consequence of changes that were applied in a early 6.2 ER, so not something the customer can have experimented at all.

Comment 14 Scott Mumford 2013-12-02 22:31:42 UTC
Thanks for the update Alessio. I've marked this for exclusion from the release notes.


Note You need to log in before you can comment on or make changes to this bug.